Added config parameters for u-boot client IP address as well as TFTP server IP address.
[openwrt/openwrt.git] / target / linux / at91-2.6 / image / u-boot / ubclient / Makefile
index c79260e45068796d5a1e329b6738999f2311f3ed..f8ff67cd1874501478aa01540b164d35d8961531 100644 (file)
@@ -6,7 +6,7 @@ crc32.c:
        ln -s ../lib_generic/crc32.c ./
 
 %.o: %.c
-       $(CC) -I ../include $(CFLAGS) $(EXTRA_FLAGS) -c -o $@ $^
+       $(CC) -I ../include $(CFLAGS) $(EXTRA_FLAGS) -DLAN_IP=$(LAN_IP) -DLAN_SERVERIP=$(LAN_SERVERIP) -c -o $@ $^
 
 ubpar: ubpar.o crc32.o
        $(CC) -o $@ $^