at91bootstrap: add sama5d27_som1_eksd1_uboot as default defconfig
[openwrt/openwrt.git] / target / linux / at91 / image / Makefile
index e4c17e3a3c9970af6a4c310505885a93c4d4235b..3a906a6ca8516b2432ad6921292cd5a8e66de3dd 100644 (file)
@@ -55,9 +55,13 @@ define Build/at91-sdcard
     $(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc/u-boot.bin \
     ::u-boot.bin
 
-  mcopy -i $@.boot \
-    $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd*/at91bootstrap.bin \
-    ::BOOT.bin
+  $(if $(findstring at91-sama5d27_som1_ek,$@), \
+      mcopy -i $@.boot \
+          $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd1_uboot/at91bootstrap.bin \
+          ::BOOT.bin,
+      mcopy -i $@.boot \
+          $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd_uboot/at91bootstrap.bin \
+          ::BOOT.bin)
 
   ./gen_at91_sdcard_img.sh \
       $@.img \