at91: add support for sam9x60-ek board
[openwrt/openwrt.git] / target / linux / at91 / image / sam9x.mk
index 6f10123bbaae37dea19cfdb89584f314789b5c78..b6c5e33ac44fe55d84e9b3d995f2431554d1d200 100644 (file)
@@ -16,11 +16,11 @@ define Build/at91-sdcard
        ::$(DEVICE_NAME)-fit.itb
 
   mcopy -i $@.boot \
-       $(BIN_DIR)/u-boot-at91sam9x5ek_mmc/u-boot.bin \
+       $(BIN_DIR)/u-boot-$(if $(findstring sam9x60,$@),$(DEVICE_DTS:at91-%=%),at91sam9x5ek)_mmc/u-boot.bin \
        ::u-boot.bin
 
   mcopy -i $@.boot \
-       $(BIN_DIR)/at91bootstrap-at91sam9x5eksd_uboot/at91bootstrap.bin \
+       $(BIN_DIR)/at91bootstrap-$(if $(findstring sam9x60,$@),$(DEVICE_DTS:at91-%=%),at91sam9x5ek)sd_uboot/at91bootstrap.bin \
        ::BOOT.bin
 
   $(CP) uboot-env.txt $@-uboot-env.txt
@@ -112,6 +112,15 @@ define Device/atmel_at91sam9x35ek
 endef
 TARGET_DEVICES += atmel_at91sam9x35ek
 
+define Device/microchip_sam9x60ek
+  $(Device/evaluation-dtb)
+  DEVICE_VENDOR := Microchip
+  DEVICE_MODEL := SAM9X60-EK
+  DEVICE_DTS := at91-sam9x60ek
+  $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += microchip_sam9x60ek
+
 define Device/calamp_lmu5000
   $(Device/production)
   DEVICE_VENDOR := CalAmp