First stage of update for at91 devices to 2.6.25.10 kernel
[openwrt/openwrt.git] / target / linux / at91 / patches-2.6.25 / 007-mtd-partition.patch
diff --git a/target/linux/at91/patches-2.6.25/007-mtd-partition.patch b/target/linux/at91/patches-2.6.25/007-mtd-partition.patch
new file mode 100644 (file)
index 0000000..5c0cd3e
--- /dev/null
@@ -0,0 +1,42 @@
+Index: linux-2.6.22.19/drivers/mtd/devices/at91_dataflash.c
+===================================================================
+--- linux-2.6.22.19.orig/drivers/mtd/devices/at91_dataflash.c
++++ linux-2.6.22.19/drivers/mtd/devices/at91_dataflash.c
+@@ -175,7 +175,7 @@ static struct mtd_partition static_parti
+ };
+ #endif
+-static const char *part_probes[] = { "cmdlinepart", NULL, };
++static const char *part_probes[] = { "cmdlinepart", "at91part", NULL, };
+ #endif
+Index: linux-2.6.22.19/drivers/mtd/Kconfig
+===================================================================
+--- linux-2.6.22.19.orig/drivers/mtd/Kconfig
++++ linux-2.6.22.19/drivers/mtd/Kconfig
+@@ -168,6 +168,12 @@ config MTD_AFS_PARTS
+         the partition map from the children of the flash node,
+         as described in Documentation/powerpc/booting-without-of.txt.
++config MTD_AT91_PARTS
++      tristate "Atmel AT91 partitioning support"
++      depends on MTD_PARTITIONS && ARCH_AT91RM9200 && AT91_SPI
++      ---help---
++        Atmel AT91 partitioning support
++      
+ comment "User Modules And Translation Layers"
+ config MTD_CHAR
+Index: linux-2.6.22.19/drivers/mtd/Makefile
+===================================================================
+--- linux-2.6.22.19.orig/drivers/mtd/Makefile
++++ linux-2.6.22.19/drivers/mtd/Makefile
+@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_CONCAT)     += mtdconcat.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS)   += afs.o
+ obj-$(CONFIG_MTD_OF_PARTS)      += ofpart.o
++obj-$(CONFIG_MTD_AT91_PARTS)   += at91part.o
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_CHAR)                += mtdchar.o