ath79: lzma-loader: sync with ar71xx target
[openwrt/openwrt.git] / target / linux / ath79 / image / Makefile
index cd136b23b9ba0365dcf6a0185bdb2997ccad77a5..34dd81961032203dfd4bbca5ba14a3082b80fece 100644 (file)
@@ -29,8 +29,9 @@ define Build/loader-okli-compile
        $(call Build/loader-common,FLASH_OFFS=$(LOADER_FLASH_OFFS) FLASH_MAX=0)
 endef
 
+# Arguments: <output name> <kernel offset>
 define Build/loader-okli
-       dd if=$(KDIR)/loader-$(1).gz bs=7680 conv=sync of="$@.new"
+       dd if=$(KDIR)/loader-$(word 1,$(1)).$(LOADER_TYPE) bs=$(word 2,$(1)) conv=sync of="$@.new"
        cat "$@" >> "$@.new"
        mv "$@.new" "$@"
 endef