ath79: add support for Netgear EX6400 and EX7300
[openwrt/openwrt.git] / target / linux / ath79 / image / common-netgear.mk
index 956266ab2c4a34e8ed2052ecef96a6b6c7371651..9b799362953a020355f5cd94865e24ca293b7c78 100644 (file)
@@ -19,6 +19,16 @@ define Build/netgear-squashfs
        rm -rf $@.squashfs $@.fs
 endef
 
+define Build/netgear-rootfs
+       mkimage \
+               -A mips -O linux -T filesystem -C none \
+               -M $(NETGEAR_KERNEL_MAGIC) \
+               -n '$(VERSION_DIST) filesystem' \
+               -d $(IMAGE_ROOTFS) $@.fs
+       cat $@.fs >> $@
+       rm -rf $@.fs
+endef
+
 define Build/netgear-uImage
        $(call Build/uImage,$(1) -M $(NETGEAR_KERNEL_MAGIC))
 endef