ath79: support for TP-Link EAP225-Outdoor v1
[openwrt/openwrt.git] / target / linux / ath79 / image / generic-tp-link.mk
index c704d99c98e04f18f28f7c0cad0c41d89e26c4ed..343ea963c372e6d08bb9f9b763cfc1f0489822dc 100644 (file)
@@ -371,6 +371,17 @@ define Device/tplink-eap2x5
        pad-extra 128
 endef
 
+define Device/tplink_eap225-outdoor-v1
+  $(Device/tplink-eap2x5)
+  SOC := qca9563
+  IMAGE_SIZE := 13824k
+  DEVICE_MODEL := EAP225-Outdoor
+  DEVICE_VARIANT := v1
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
+  TPLINK_BOARD_ID := EAP225-OUTDOOR-V1
+endef
+TARGET_DEVICES += tplink_eap225-outdoor-v1
+
 define Device/tplink_eap225-wall-v2
   $(Device/tplink-eap2x5)
   SOC := qca9561