ath79: support for TP-Link EAP225 v4
[openwrt/openwrt.git] / target / linux / ath79 / image / generic-tp-link.mk
index ffe999660acb7534110e7944a1b677565e01ac0d..6d9ba2cd40342744ce6d86c2a23b349367b53220 100644 (file)
@@ -434,6 +434,17 @@ define Device/tplink_eap225-v3
 endef
 TARGET_DEVICES += tplink_eap225-v3
 
+define Device/tplink_eap225-v4
+  $(Device/tplink-eap2x5)
+  SOC := qca9563
+  IMAGE_SIZE := 13824k
+  DEVICE_MODEL := EAP225
+  DEVICE_VARIANT := v4
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
+  TPLINK_BOARD_ID := EAP225-V3
+endef
+TARGET_DEVICES += tplink_eap225-v4
+
 define Device/tplink_eap225-wall-v2
   $(Device/tplink-eap2x5)
   SOC := qca9561