ath79: move D-Link DAP-1720 A1 to tiny sub-target
[openwrt/openwrt.git] / target / linux / ath79 / image / tiny.mk
index 13f105d2028a1b30cb927479153f7ad30b90741d..955d0fbff22c0b61b9b06d3ad08dd5c77632eab1 100644 (file)
@@ -12,6 +12,19 @@ define Device/buffalo_whr-g301n
 endef
 TARGET_DEVICES += buffalo_whr-g301n
 
+define Device/dlink_dap-1720-a1
+  $(Device/seama)
+  SOC := qca9563
+  DEVICE_VENDOR := D-Link
+  DEVICE_MODEL := DAP-1720
+  DEVICE_VARIANT := A1
+  IMAGE_SIZE := 15872k
+  SEAMA_SIGNATURE := wapac28_dlink.2015_dap1720
+  DEVICE_PACKAGES := -swconfig ath10k-firmware-qca988x-ct \
+       kmod-ath10k-ct-smallbuffers rssileds
+endef
+TARGET_DEVICES += dlink_dap-1720-a1
+
 define Device/dlink_dir-615-e4
   SOC := ar7240
   DEVICE_VENDOR := D-Link