kernel: move ubnt ledbar driver to a separate package
[openwrt/openwrt.git] / target / linux / ath79 / patches-5.15 / 0003-leds-add-reset-controller-based-driver.patch
index f958e79608ac9fcc578c5439793541a6557b2ce9..7122756c526687e46d9565fbb0e16fe06f319cef 100644 (file)
@@ -13,9 +13,9 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -886,6 +886,17 @@ config LEDS_UBNT_LEDBAR
-         To compile this driver as a module, choose M here: the module
-         will be called leds-ubnt-ledbar.
+@@ -876,6 +876,17 @@ source "drivers/leds/blink/Kconfig"
+ comment "Flash and Torch LED drivers"
+ source "drivers/leds/flash/Kconfig"
  
 +config LEDS_RESET
 +      tristate "LED support for reset-controller API"
@@ -176,10 +176,10 @@ Signed-off-by: John Crispin <john@phrozen.org>
 +MODULE_ALIAS("platform:leds-reset");
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -88,6 +88,7 @@ obj-$(CONFIG_LEDS_WM831X_STATUS)     += leds
+@@ -87,6 +87,7 @@ obj-$(CONFIG_LEDS_TURRIS_OMNIA)              += leds
+ obj-$(CONFIG_LEDS_WM831X_STATUS)      += leds-wm831x-status.o
  obj-$(CONFIG_LEDS_WM8350)             += leds-wm8350.o
  obj-$(CONFIG_LEDS_WRAP)                       += leds-wrap.o
- obj-$(CONFIG_LEDS_UBNT_LEDBAR)                += leds-ubnt-ledbar.o
 +obj-$(CONFIG_LEDS_RESET)              += leds-reset.o
  
  # LED SPI Drivers