bcm53xx: add support for ASUS RT-AC3100
[openwrt/openwrt.git] / target / linux / bcm53xx / image / Makefile
index f2c145a375f5c2aa62c18e355d601b863caa981f..312e5d62b7cb8eb7624403e04122c510a4ef28a0 100644 (file)
@@ -143,6 +143,15 @@ define Device/asus
   IMAGE/trx := append-ubi | trx-nand | asus-trx
 endef
 
+define Device/asus_rt-ac3100
+  $(call Device/asus)
+  DEVICE_MODEL := RT-AC3100
+  DEVICE_PACKAGES := $(BRCMFMAC_4366B1) $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
+  ASUS_PRODUCTID := RT-AC3100
+  DEFAULT := n
+endef
+TARGET_DEVICES += asus_rt-ac3100
+
 define Device/asus_rt-ac56u
   $(call Device/asus)
   DEVICE_MODEL := RT-AC56U