bcm53xx: add pending BCM5301X patches: Netgear R8000 WiFi & Luxul DTS
[openwrt/openwrt.git] / target / linux / bcm53xx / patches-4.4 / 130-0003-ARM-BCM5301X-Add-DT-for-Luxul-XWR-1200.patch
diff --git a/target/linux/bcm53xx/patches-4.4/130-0003-ARM-BCM5301X-Add-DT-for-Luxul-XWR-1200.patch b/target/linux/bcm53xx/patches-4.4/130-0003-ARM-BCM5301X-Add-DT-for-Luxul-XWR-1200.patch
new file mode 100644 (file)
index 0000000..ba1907c
--- /dev/null
@@ -0,0 +1,133 @@
+From: Dan Haab <dhaab@luxul.com>
+Subject: [PATCH] ARM: BCM5301X: Add DT for Luxul XWR-1200
+
+Luxul XWR-1200 in a dual-band router based on BCM47081. It uses serial
+flash (for bootloader and NVRAM) and NAND flash (for firmware).
+
+Signed-off-by: Dan Haab <dhaab@luxul.com>
+---
+ arch/arm/boot/dts/Makefile                    |   1 +
+ arch/arm/boot/dts/bcm47081-luxul-xwr-1200.dts | 107 ++++++++++++++++++++++++++
+ 2 files changed, 108 insertions(+)
+ create mode 100644 arch/arm/boot/dts/bcm47081-luxul-xwr-1200.dts
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -74,6 +74,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+       bcm47081-buffalo-wzr-600dhp2.dtb \
+       bcm47081-buffalo-wzr-900dhp.dtb \
+       bcm47081-luxul-xap-1410.dtb \
++      bcm47081-luxul-xwr-1200.dtb \
+       bcm4709-asus-rt-ac87u.dtb \
+       bcm4709-buffalo-wxr-1900dhp.dtb \
+       bcm4709-netgear-r7000.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm47081-luxul-xwr-1200.dts
+@@ -0,0 +1,107 @@
++/*
++ * Copyright 2017 Luxul Inc.
++ *
++ * Licensed under the ISC license.
++ */
++
++/dts-v1/;
++
++#include "bcm47081.dtsi"
++#include "bcm5301x-nand-cs0-bch4.dtsi"
++
++/ {
++      compatible = "luxul,xwr-1200v1", "brcm,bcm47081", "brcm,bcm4708";
++      model = "Luxul XWR-1200 V1";
++
++      chosen {
++              bootargs = "console=ttyS0,115200";
++      };
++
++      memory {
++              reg = <0x00000000 0x08000000>;
++      };
++
++      leds {
++              compatible = "gpio-leds";
++
++              power {
++                      label = "bcm53xx:green:power";
++                      gpios = <&chipcommon 0 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "default-on";
++              };
++
++              lan3 {
++                      label = "bcm53xx:green:lan3";
++                      gpios = <&chipcommon 1 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "none";
++              };
++
++              lan4 {
++                      label = "bcm53xx:green:lan4";
++                      gpios = <&chipcommon 2 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "none";
++              };
++
++              wan {
++                      label = "bcm53xx:green:wan";
++                      gpios = <&chipcommon 3 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "none";
++              };
++
++              lan2 {
++                      label = "bcm53xx:green:lan2";
++                      gpios = <&chipcommon 6 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "none";
++              };
++
++              usb {
++                      label = "bcm53xx:green:usb";
++                      gpios = <&chipcommon 8 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "none";
++              };
++
++              status {
++                      label = "bcm53xx:green:status";
++                      gpios = <&chipcommon 10 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "timer";
++              };
++
++              2ghz {
++                      label = "bcm53xx:green:2ghz";
++                      gpios = <&chipcommon 13 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "none";
++              };
++
++              5ghz {
++                      label = "bcm53xx:green:5ghz";
++                      gpios = <&chipcommon 14 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "none";
++              };
++
++              lan1 {
++                      label = "bcm53xx:green:lan1";
++                      gpios = <&chipcommon 15 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "none";
++              };
++      };
++
++      gpio-keys {
++              compatible = "gpio-keys";
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              restart {
++                      label = "Reset";
++                      linux,code = <KEY_RESTART>;
++                      gpios = <&chipcommon 11 GPIO_ACTIVE_LOW>;
++              };
++      };
++};
++
++&usb2 {
++      vcc-gpio = <&chipcommon 9 GPIO_ACTIVE_HIGH>;
++};
++
++&spi_nor {
++      status = "okay";
++};