brcm2708: rename target to bcm27xx
[openwrt/openwrt.git] / target / linux / brcm2708 / patches-4.19 / 950-0067-Added-support-for-HiFiBerry-DAC.patch
diff --git a/target/linux/brcm2708/patches-4.19/950-0067-Added-support-for-HiFiBerry-DAC.patch b/target/linux/brcm2708/patches-4.19/950-0067-Added-support-for-HiFiBerry-DAC.patch
deleted file mode 100644 (file)
index a335e2d..0000000
+++ /dev/null
@@ -1,595 +0,0 @@
-From 86d09076abd36ad87477c21f7b33c90cb696e196 Mon Sep 17 00:00:00 2001
-From: Daniel Matuschek <info@crazy-audio.com>
-Date: Mon, 4 Aug 2014 10:06:56 +0200
-Subject: [PATCH] Added support for HiFiBerry DAC+
-
-The driver is based on the HiFiBerry DAC driver. However HiFiBerry DAC+ uses
-a different codec chip (PCM5122), therefore a new driver is necessary.
-
-Add support for the HiFiBerry DAC+ Pro.
-
-The HiFiBerry DAC+ and DAC+ Pro products both use the existing bcm sound driver with the DAC+ Pro having a special clock device driver representing the two high precision oscillators.
-
-An addition bug fix is included for the PCM512x codec where by the physical size of the sample frame is used in the calculation of the LRCK divisor as it was found to be wrong when using 24-bit depth sample contained in a little endian 4-byte sample frame.
-
-Limit PCM512x "Digital" gain to 0dB by default with HiFiBerry DAC+
-
-24db_digital_gain DT param can be used to specify that PCM512x
-codec "Digital" volume control should not be limited to 0dB gain,
-and if specified will allow the full 24dB gain.
-
-Add dt param to force HiFiBerry DAC+ Pro into slave mode
-
-"dtoverlay=hifiberry-dacplus,slave"
-
-Add 'slave' param to use HiFiBerry DAC+ Pro in slave mode,
-with Pi as master for bit and frame clock.
-
-Signed-off-by: DigitalDreamtime <clive.messer@digitaldreamtime.co.uk>
-
-Fixed a bug when using 352.8kHz sample rate
-
-Signed-off-by: Daniel Matuschek <daniel@hifiberry.com>
-
-ASoC: pcm512x: revert downstream changes
-
-This partially reverts commit 185ea05465aac8bf02a0d2b2f4289d42c72870b7
-which was added by https://github.com/raspberrypi/linux/pull/1152
-
-The downstream pcm512x changes caused a regression, it broke normal
-use of the 24bit format with the codec, eg when using simple-audio-card.
-
-The actual bug with 24bit playback is the incorrect usage
-of physical_width in various drivers in the downstream tree
-which causes 24bit data to be transmitted with 32 clock
-cycles. So it's not the pcm512x that needs fixing, it's the
-soundcard drivers.
-
-Signed-off-by: Matthias Reichl <hias@horus.com>
-
-ASoC: hifiberry_dacplus: fix S24_LE format
-
-Remove set_bclk_ratio call so 24-bit data is transmitted in
-24 bclk cycles.
-
-Signed-off-by: Matthias Reichl <hias@horus.com>
-
-ASoC: hifiberry_dacplus: transmit S24_LE with 64 BCLK cycles
-
-Signed-off-by: Matthias Reichl <hias@horus.com>
----
- drivers/clk/Makefile               |   1 +
- drivers/clk/clk-hifiberry-dacpro.c | 160 +++++++++++++
- sound/soc/bcm/hifiberry_dacplus.c  | 352 +++++++++++++++++++++++++++++
- 3 files changed, 513 insertions(+)
- create mode 100644 drivers/clk/clk-hifiberry-dacpro.c
- create mode 100644 sound/soc/bcm/hifiberry_dacplus.c
-
---- a/drivers/clk/Makefile
-+++ b/drivers/clk/Makefile
-@@ -30,6 +30,7 @@ obj-$(CONFIG_COMMON_CLK_GEMINI)              += clk-
- obj-$(CONFIG_COMMON_CLK_ASPEED)               += clk-aspeed.o
- obj-$(CONFIG_ARCH_HIGHBANK)           += clk-highbank.o
- obj-$(CONFIG_CLK_HSDK)                        += clk-hsdk-pll.o
-+obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DACPLUS) += clk-hifiberry-dacpro.o
- obj-$(CONFIG_COMMON_CLK_MAX77686)     += clk-max77686.o
- obj-$(CONFIG_COMMON_CLK_MAX9485)      += clk-max9485.o
- obj-$(CONFIG_ARCH_MOXART)             += clk-moxart.o
---- /dev/null
-+++ b/drivers/clk/clk-hifiberry-dacpro.c
-@@ -0,0 +1,160 @@
-+/*
-+ * Clock Driver for HiFiBerry DAC Pro
-+ *
-+ * Author: Stuart MacLean
-+ *         Copyright 2015
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License
-+ * version 2 as published by the Free Software Foundation.
-+ *
-+ * This program is distributed in the hope that it will be useful, but
-+ * WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-+ * General Public License for more details.
-+ */
-+
-+#include <linux/clk-provider.h>
-+#include <linux/clkdev.h>
-+#include <linux/kernel.h>
-+#include <linux/module.h>
-+#include <linux/of.h>
-+#include <linux/slab.h>
-+#include <linux/platform_device.h>
-+
-+/* Clock rate of CLK44EN attached to GPIO6 pin */
-+#define CLK_44EN_RATE 22579200UL
-+/* Clock rate of CLK48EN attached to GPIO3 pin */
-+#define CLK_48EN_RATE 24576000UL
-+
-+/**
-+ * struct hifiberry_dacpro_clk - Common struct to the HiFiBerry DAC Pro
-+ * @hw: clk_hw for the common clk framework
-+ * @mode: 0 => CLK44EN, 1 => CLK48EN
-+ */
-+struct clk_hifiberry_hw {
-+      struct clk_hw hw;
-+      uint8_t mode;
-+};
-+
-+#define to_hifiberry_clk(_hw) container_of(_hw, struct clk_hifiberry_hw, hw)
-+
-+static const struct of_device_id clk_hifiberry_dacpro_dt_ids[] = {
-+      { .compatible = "hifiberry,dacpro-clk",},
-+      { }
-+};
-+MODULE_DEVICE_TABLE(of, clk_hifiberry_dacpro_dt_ids);
-+
-+static unsigned long clk_hifiberry_dacpro_recalc_rate(struct clk_hw *hw,
-+      unsigned long parent_rate)
-+{
-+      return (to_hifiberry_clk(hw)->mode == 0) ? CLK_44EN_RATE :
-+              CLK_48EN_RATE;
-+}
-+
-+static long clk_hifiberry_dacpro_round_rate(struct clk_hw *hw,
-+      unsigned long rate, unsigned long *parent_rate)
-+{
-+      long actual_rate;
-+
-+      if (rate <= CLK_44EN_RATE) {
-+              actual_rate = (long)CLK_44EN_RATE;
-+      } else if (rate >= CLK_48EN_RATE) {
-+              actual_rate = (long)CLK_48EN_RATE;
-+      } else {
-+              long diff44Rate = (long)(rate - CLK_44EN_RATE);
-+              long diff48Rate = (long)(CLK_48EN_RATE - rate);
-+
-+              if (diff44Rate < diff48Rate)
-+                      actual_rate = (long)CLK_44EN_RATE;
-+              else
-+                      actual_rate = (long)CLK_48EN_RATE;
-+      }
-+      return actual_rate;
-+}
-+
-+
-+static int clk_hifiberry_dacpro_set_rate(struct clk_hw *hw,
-+      unsigned long rate, unsigned long parent_rate)
-+{
-+      unsigned long actual_rate;
-+      struct clk_hifiberry_hw *clk = to_hifiberry_clk(hw);
-+
-+      actual_rate = (unsigned long)clk_hifiberry_dacpro_round_rate(hw, rate,
-+              &parent_rate);
-+      clk->mode = (actual_rate == CLK_44EN_RATE) ? 0 : 1;
-+      return 0;
-+}
-+
-+
-+const struct clk_ops clk_hifiberry_dacpro_rate_ops = {
-+      .recalc_rate = clk_hifiberry_dacpro_recalc_rate,
-+      .round_rate = clk_hifiberry_dacpro_round_rate,
-+      .set_rate = clk_hifiberry_dacpro_set_rate,
-+};
-+
-+static int clk_hifiberry_dacpro_probe(struct platform_device *pdev)
-+{
-+      int ret;
-+      struct clk_hifiberry_hw *proclk;
-+      struct clk *clk;
-+      struct device *dev;
-+      struct clk_init_data init;
-+
-+      dev = &pdev->dev;
-+
-+      proclk = kzalloc(sizeof(struct clk_hifiberry_hw), GFP_KERNEL);
-+      if (!proclk)
-+              return -ENOMEM;
-+
-+      init.name = "clk-hifiberry-dacpro";
-+      init.ops = &clk_hifiberry_dacpro_rate_ops;
-+      init.flags = CLK_IS_BASIC;
-+      init.parent_names = NULL;
-+      init.num_parents = 0;
-+
-+      proclk->mode = 0;
-+      proclk->hw.init = &init;
-+
-+      clk = devm_clk_register(dev, &proclk->hw);
-+      if (!IS_ERR(clk)) {
-+              ret = of_clk_add_provider(dev->of_node, of_clk_src_simple_get,
-+                      clk);
-+      } else {
-+              dev_err(dev, "Fail to register clock driver\n");
-+              kfree(proclk);
-+              ret = PTR_ERR(clk);
-+      }
-+      return ret;
-+}
-+
-+static int clk_hifiberry_dacpro_remove(struct platform_device *pdev)
-+{
-+      of_clk_del_provider(pdev->dev.of_node);
-+      return 0;
-+}
-+
-+static struct platform_driver clk_hifiberry_dacpro_driver = {
-+      .probe = clk_hifiberry_dacpro_probe,
-+      .remove = clk_hifiberry_dacpro_remove,
-+      .driver = {
-+              .name = "clk-hifiberry-dacpro",
-+              .of_match_table = clk_hifiberry_dacpro_dt_ids,
-+      },
-+};
-+
-+static int __init clk_hifiberry_dacpro_init(void)
-+{
-+      return platform_driver_register(&clk_hifiberry_dacpro_driver);
-+}
-+core_initcall(clk_hifiberry_dacpro_init);
-+
-+static void __exit clk_hifiberry_dacpro_exit(void)
-+{
-+      platform_driver_unregister(&clk_hifiberry_dacpro_driver);
-+}
-+module_exit(clk_hifiberry_dacpro_exit);
-+
-+MODULE_DESCRIPTION("HiFiBerry DAC Pro clock driver");
-+MODULE_LICENSE("GPL v2");
-+MODULE_ALIAS("platform:clk-hifiberry-dacpro");
---- /dev/null
-+++ b/sound/soc/bcm/hifiberry_dacplus.c
-@@ -0,0 +1,352 @@
-+/*
-+ * ASoC Driver for HiFiBerry DAC+ / DAC Pro
-+ *
-+ * Author:    Daniel Matuschek, Stuart MacLean <stuart@hifiberry.com>
-+ *            Copyright 2014-2015
-+ *            based on code by Florian Meier <florian.meier@koalo.de>
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License
-+ * version 2 as published by the Free Software Foundation.
-+ *
-+ * This program is distributed in the hope that it will be useful, but
-+ * WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-+ * General Public License for more details.
-+ */
-+
-+#include <linux/module.h>
-+#include <linux/platform_device.h>
-+#include <linux/kernel.h>
-+#include <linux/clk.h>
-+#include <linux/kernel.h>
-+#include <linux/module.h>
-+#include <linux/of.h>
-+#include <linux/slab.h>
-+#include <linux/delay.h>
-+
-+#include <sound/core.h>
-+#include <sound/pcm.h>
-+#include <sound/pcm_params.h>
-+#include <sound/soc.h>
-+#include <sound/jack.h>
-+
-+#include "../codecs/pcm512x.h"
-+
-+#define HIFIBERRY_DACPRO_NOCLOCK 0
-+#define HIFIBERRY_DACPRO_CLK44EN 1
-+#define HIFIBERRY_DACPRO_CLK48EN 2
-+
-+struct pcm512x_priv {
-+      struct regmap *regmap;
-+      struct clk *sclk;
-+};
-+
-+/* Clock rate of CLK44EN attached to GPIO6 pin */
-+#define CLK_44EN_RATE 22579200UL
-+/* Clock rate of CLK48EN attached to GPIO3 pin */
-+#define CLK_48EN_RATE 24576000UL
-+
-+static bool slave;
-+static bool snd_rpi_hifiberry_is_dacpro;
-+static bool digital_gain_0db_limit = true;
-+
-+static void snd_rpi_hifiberry_dacplus_select_clk(struct snd_soc_component *component,
-+      int clk_id)
-+{
-+      switch (clk_id) {
-+      case HIFIBERRY_DACPRO_NOCLOCK:
-+              snd_soc_component_update_bits(component, PCM512x_GPIO_CONTROL_1, 0x24, 0x00);
-+              break;
-+      case HIFIBERRY_DACPRO_CLK44EN:
-+              snd_soc_component_update_bits(component, PCM512x_GPIO_CONTROL_1, 0x24, 0x20);
-+              break;
-+      case HIFIBERRY_DACPRO_CLK48EN:
-+              snd_soc_component_update_bits(component, PCM512x_GPIO_CONTROL_1, 0x24, 0x04);
-+              break;
-+      }
-+}
-+
-+static void snd_rpi_hifiberry_dacplus_clk_gpio(struct snd_soc_component *component)
-+{
-+      snd_soc_component_update_bits(component, PCM512x_GPIO_EN, 0x24, 0x24);
-+      snd_soc_component_update_bits(component, PCM512x_GPIO_OUTPUT_3, 0x0f, 0x02);
-+      snd_soc_component_update_bits(component, PCM512x_GPIO_OUTPUT_6, 0x0f, 0x02);
-+}
-+
-+static bool snd_rpi_hifiberry_dacplus_is_sclk(struct snd_soc_component *component)
-+{
-+      unsigned int sck;
-+
-+      snd_soc_component_read(component, PCM512x_RATE_DET_4, &sck);
-+      return (!(sck & 0x40));
-+}
-+
-+static bool snd_rpi_hifiberry_dacplus_is_sclk_sleep(
-+      struct snd_soc_component *component)
-+{
-+      msleep(2);
-+      return snd_rpi_hifiberry_dacplus_is_sclk(component);
-+}
-+
-+static bool snd_rpi_hifiberry_dacplus_is_pro_card(struct snd_soc_component *component)
-+{
-+      bool isClk44EN, isClk48En, isNoClk;
-+
-+      snd_rpi_hifiberry_dacplus_clk_gpio(component);
-+
-+      snd_rpi_hifiberry_dacplus_select_clk(component, HIFIBERRY_DACPRO_CLK44EN);
-+      isClk44EN = snd_rpi_hifiberry_dacplus_is_sclk_sleep(component);
-+
-+      snd_rpi_hifiberry_dacplus_select_clk(component, HIFIBERRY_DACPRO_NOCLOCK);
-+      isNoClk = snd_rpi_hifiberry_dacplus_is_sclk_sleep(component);
-+
-+      snd_rpi_hifiberry_dacplus_select_clk(component, HIFIBERRY_DACPRO_CLK48EN);
-+      isClk48En = snd_rpi_hifiberry_dacplus_is_sclk_sleep(component);
-+
-+      return (isClk44EN && isClk48En && !isNoClk);
-+}
-+
-+static int snd_rpi_hifiberry_dacplus_clk_for_rate(int sample_rate)
-+{
-+      int type;
-+
-+      switch (sample_rate) {
-+      case 11025:
-+      case 22050:
-+      case 44100:
-+      case 88200:
-+      case 176400:
-+      case 352800:
-+              type = HIFIBERRY_DACPRO_CLK44EN;
-+              break;
-+      default:
-+              type = HIFIBERRY_DACPRO_CLK48EN;
-+              break;
-+      }
-+      return type;
-+}
-+
-+static void snd_rpi_hifiberry_dacplus_set_sclk(struct snd_soc_component *component,
-+      int sample_rate)
-+{
-+      struct pcm512x_priv *pcm512x = snd_soc_component_get_drvdata(component);
-+
-+      if (!IS_ERR(pcm512x->sclk)) {
-+              int ctype;
-+
-+              ctype = snd_rpi_hifiberry_dacplus_clk_for_rate(sample_rate);
-+              clk_set_rate(pcm512x->sclk, (ctype == HIFIBERRY_DACPRO_CLK44EN)
-+                      ? CLK_44EN_RATE : CLK_48EN_RATE);
-+              snd_rpi_hifiberry_dacplus_select_clk(component, ctype);
-+      }
-+}
-+
-+static int snd_rpi_hifiberry_dacplus_init(struct snd_soc_pcm_runtime *rtd)
-+{
-+      struct snd_soc_component *component = rtd->codec_dai->component;
-+      struct pcm512x_priv *priv;
-+
-+      if (slave)
-+              snd_rpi_hifiberry_is_dacpro = false;
-+      else
-+              snd_rpi_hifiberry_is_dacpro =
-+                              snd_rpi_hifiberry_dacplus_is_pro_card(component);
-+
-+      if (snd_rpi_hifiberry_is_dacpro) {
-+              struct snd_soc_dai_link *dai = rtd->dai_link;
-+
-+              dai->name = "HiFiBerry DAC+ Pro";
-+              dai->stream_name = "HiFiBerry DAC+ Pro HiFi";
-+              dai->dai_fmt = SND_SOC_DAIFMT_I2S | SND_SOC_DAIFMT_NB_NF
-+                      | SND_SOC_DAIFMT_CBM_CFM;
-+
-+              snd_soc_component_update_bits(component, PCM512x_BCLK_LRCLK_CFG, 0x31, 0x11);
-+              snd_soc_component_update_bits(component, PCM512x_MASTER_MODE, 0x03, 0x03);
-+              snd_soc_component_update_bits(component, PCM512x_MASTER_CLKDIV_2, 0x7f, 63);
-+      } else {
-+              priv = snd_soc_component_get_drvdata(component);
-+              priv->sclk = ERR_PTR(-ENOENT);
-+      }
-+
-+      snd_soc_component_update_bits(component, PCM512x_GPIO_EN, 0x08, 0x08);
-+      snd_soc_component_update_bits(component, PCM512x_GPIO_OUTPUT_4, 0x0f, 0x02);
-+      snd_soc_component_update_bits(component, PCM512x_GPIO_CONTROL_1, 0x08, 0x08);
-+
-+      if (digital_gain_0db_limit)
-+      {
-+              int ret;
-+              struct snd_soc_card *card = rtd->card;
-+
-+              ret = snd_soc_limit_volume(card, "Digital Playback Volume", 207);
-+              if (ret < 0)
-+                      dev_warn(card->dev, "Failed to set volume limit: %d\n", ret);
-+      }
-+
-+      return 0;
-+}
-+
-+static int snd_rpi_hifiberry_dacplus_update_rate_den(
-+      struct snd_pcm_substream *substream, struct snd_pcm_hw_params *params)
-+{
-+      struct snd_soc_pcm_runtime *rtd = substream->private_data;
-+      struct snd_soc_component *component = rtd->codec_dai->component;
-+      struct pcm512x_priv *pcm512x = snd_soc_component_get_drvdata(component);
-+      struct snd_ratnum *rats_no_pll;
-+      unsigned int num = 0, den = 0;
-+      int err;
-+
-+      rats_no_pll = devm_kzalloc(rtd->dev, sizeof(*rats_no_pll), GFP_KERNEL);
-+      if (!rats_no_pll)
-+              return -ENOMEM;
-+
-+      rats_no_pll->num = clk_get_rate(pcm512x->sclk) / 64;
-+      rats_no_pll->den_min = 1;
-+      rats_no_pll->den_max = 128;
-+      rats_no_pll->den_step = 1;
-+
-+      err = snd_interval_ratnum(hw_param_interval(params,
-+              SNDRV_PCM_HW_PARAM_RATE), 1, rats_no_pll, &num, &den);
-+      if (err >= 0 && den) {
-+              params->rate_num = num;
-+              params->rate_den = den;
-+      }
-+
-+      devm_kfree(rtd->dev, rats_no_pll);
-+      return 0;
-+}
-+
-+static int snd_rpi_hifiberry_dacplus_hw_params(
-+      struct snd_pcm_substream *substream, struct snd_pcm_hw_params *params)
-+{
-+      int ret = 0;
-+      struct snd_soc_pcm_runtime *rtd = substream->private_data;
-+      int channels = params_channels(params);
-+      int width = 32;
-+
-+      if (snd_rpi_hifiberry_is_dacpro) {
-+              struct snd_soc_component *component = rtd->codec_dai->component;
-+
-+              width = snd_pcm_format_physical_width(params_format(params));
-+
-+              snd_rpi_hifiberry_dacplus_set_sclk(component,
-+                      params_rate(params));
-+
-+              ret = snd_rpi_hifiberry_dacplus_update_rate_den(
-+                      substream, params);
-+      }
-+
-+      ret = snd_soc_dai_set_tdm_slot(rtd->cpu_dai, 0x03, 0x03,
-+              channels, width);
-+      if (ret)
-+              return ret;
-+      ret = snd_soc_dai_set_tdm_slot(rtd->codec_dai, 0x03, 0x03,
-+              channels, width);
-+      return ret;
-+}
-+
-+static int snd_rpi_hifiberry_dacplus_startup(
-+      struct snd_pcm_substream *substream)
-+{
-+      struct snd_soc_pcm_runtime *rtd = substream->private_data;
-+      struct snd_soc_component *component = rtd->codec_dai->component;
-+
-+      snd_soc_component_update_bits(component, PCM512x_GPIO_CONTROL_1, 0x08, 0x08);
-+      return 0;
-+}
-+
-+static void snd_rpi_hifiberry_dacplus_shutdown(
-+      struct snd_pcm_substream *substream)
-+{
-+      struct snd_soc_pcm_runtime *rtd = substream->private_data;
-+      struct snd_soc_component *component = rtd->codec_dai->component;
-+
-+      snd_soc_component_update_bits(component, PCM512x_GPIO_CONTROL_1, 0x08, 0x00);
-+}
-+
-+/* machine stream operations */
-+static struct snd_soc_ops snd_rpi_hifiberry_dacplus_ops = {
-+      .hw_params = snd_rpi_hifiberry_dacplus_hw_params,
-+      .startup = snd_rpi_hifiberry_dacplus_startup,
-+      .shutdown = snd_rpi_hifiberry_dacplus_shutdown,
-+};
-+
-+static struct snd_soc_dai_link snd_rpi_hifiberry_dacplus_dai[] = {
-+{
-+      .name           = "HiFiBerry DAC+",
-+      .stream_name    = "HiFiBerry DAC+ HiFi",
-+      .cpu_dai_name   = "bcm2708-i2s.0",
-+      .codec_dai_name = "pcm512x-hifi",
-+      .platform_name  = "bcm2708-i2s.0",
-+      .codec_name     = "pcm512x.1-004d",
-+      .dai_fmt        = SND_SOC_DAIFMT_I2S | SND_SOC_DAIFMT_NB_NF |
-+                              SND_SOC_DAIFMT_CBS_CFS,
-+      .ops            = &snd_rpi_hifiberry_dacplus_ops,
-+      .init           = snd_rpi_hifiberry_dacplus_init,
-+},
-+};
-+
-+/* audio machine driver */
-+static struct snd_soc_card snd_rpi_hifiberry_dacplus = {
-+      .name         = "snd_rpi_hifiberry_dacplus",
-+      .driver_name  = "HifiberryDacp",
-+      .owner        = THIS_MODULE,
-+      .dai_link     = snd_rpi_hifiberry_dacplus_dai,
-+      .num_links    = ARRAY_SIZE(snd_rpi_hifiberry_dacplus_dai),
-+};
-+
-+static int snd_rpi_hifiberry_dacplus_probe(struct platform_device *pdev)
-+{
-+      int ret = 0;
-+
-+      snd_rpi_hifiberry_dacplus.dev = &pdev->dev;
-+      if (pdev->dev.of_node) {
-+              struct device_node *i2s_node;
-+              struct snd_soc_dai_link *dai;
-+
-+              dai = &snd_rpi_hifiberry_dacplus_dai[0];
-+              i2s_node = of_parse_phandle(pdev->dev.of_node,
-+                      "i2s-controller", 0);
-+
-+              if (i2s_node) {
-+                      dai->cpu_dai_name = NULL;
-+                      dai->cpu_of_node = i2s_node;
-+                      dai->platform_name = NULL;
-+                      dai->platform_of_node = i2s_node;
-+              }
-+
-+              digital_gain_0db_limit = !of_property_read_bool(
-+                      pdev->dev.of_node, "hifiberry,24db_digital_gain");
-+              slave = of_property_read_bool(pdev->dev.of_node,
-+                                              "hifiberry-dacplus,slave");
-+      }
-+
-+      ret = devm_snd_soc_register_card(&pdev->dev,
-+                      &snd_rpi_hifiberry_dacplus);
-+      if (ret && ret != -EPROBE_DEFER)
-+              dev_err(&pdev->dev,
-+                      "snd_soc_register_card() failed: %d\n", ret);
-+
-+      return ret;
-+}
-+
-+static const struct of_device_id snd_rpi_hifiberry_dacplus_of_match[] = {
-+      { .compatible = "hifiberry,hifiberry-dacplus", },
-+      {},
-+};
-+MODULE_DEVICE_TABLE(of, snd_rpi_hifiberry_dacplus_of_match);
-+
-+static struct platform_driver snd_rpi_hifiberry_dacplus_driver = {
-+      .driver = {
-+              .name   = "snd-rpi-hifiberry-dacplus",
-+              .owner  = THIS_MODULE,
-+              .of_match_table = snd_rpi_hifiberry_dacplus_of_match,
-+      },
-+      .probe          = snd_rpi_hifiberry_dacplus_probe,
-+};
-+
-+module_platform_driver(snd_rpi_hifiberry_dacplus_driver);
-+
-+MODULE_AUTHOR("Daniel Matuschek <daniel@hifiberry.com>");
-+MODULE_DESCRIPTION("ASoC Driver for HiFiBerry DAC+");
-+MODULE_LICENSE("GPL v2");