brcm2708: update to latest patches from RPi foundation
[openwrt/openwrt.git] / target / linux / brcm2708 / patches-4.19 / 950-0437-BCM270X_DT-Rename-Pi-Zero-W-DT-files.patch
diff --git a/target/linux/brcm2708/patches-4.19/950-0437-BCM270X_DT-Rename-Pi-Zero-W-DT-files.patch b/target/linux/brcm2708/patches-4.19/950-0437-BCM270X_DT-Rename-Pi-Zero-W-DT-files.patch
new file mode 100644 (file)
index 0000000..37bb4fd
--- /dev/null
@@ -0,0 +1,367 @@
+From 9542646d9211ab4305beb75da97f61cc1968ae6c Mon Sep 17 00:00:00 2001
+From: Phil Elwell <phil@raspberrypi.org>
+Date: Tue, 28 May 2019 16:36:04 +0100
+Subject: [PATCH] BCM270X_DT: Rename Pi Zero W DT files
+
+The downtream Pi Zero W dts file uses the digit 0, whereas upstream
+chose to spell it out - "zero-w". The firmware has, for a long time,
+looked for bcm2708-rpi-zero-w.dtb first before falling back to the
+numerical version. Therefore it is better to follow upstream and
+make the switch to "bcm2708-rpi-zero-w".
+
+At the same time, remove some overrides that duplicate values
+inherited from the shared .dtsi files.
+
+Signed-off-by: Phil Elwell <phil@raspberrypi.org>
+---
+ arch/arm/boot/dts/Makefile                                   | 2 +-
+ .../boot/dts/{bcm2708-rpi-0-w.dts => bcm2708-rpi-zero-w.dts} | 5 -----
+ 2 files changed, 1 insertion(+), 6 deletions(-)
+ rename arch/arm/boot/dts/{bcm2708-rpi-0-w.dts => bcm2708-rpi-zero-w.dts} (97%)
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -4,7 +4,7 @@ dtb-$(CONFIG_ARCH_BCM2835) += \
+       bcm2708-rpi-b.dtb \
+       bcm2708-rpi-b-plus.dtb \
+       bcm2708-rpi-cm.dtb \
+-      bcm2708-rpi-0-w.dtb \
++      bcm2708-rpi-zero-w.dtb \
+       bcm2709-rpi-2-b.dtb \
+       bcm2710-rpi-3-b.dtb \
+       bcm2710-rpi-3-b-plus.dtb \
+--- a/arch/arm/boot/dts/bcm2708-rpi-0-w.dts
++++ /dev/null
+@@ -1,167 +0,0 @@
+-/dts-v1/;
+-
+-#include "bcm2708.dtsi"
+-#include "bcm283x-rpi-csi1-2lane.dtsi"
+-
+-/ {
+-      compatible = "raspberrypi,model-zero-w", "brcm,bcm2835";
+-      model = "Raspberry Pi Zero W";
+-
+-      chosen {
+-              bootargs = "coherent_pool=1M 8250.nr_uarts=1";
+-      };
+-
+-      aliases {
+-              serial0 = &uart1;
+-              serial1 = &uart0;
+-              mmc1 = &mmcnr;
+-      };
+-};
+-
+-&gpio {
+-      spi0_pins: spi0_pins {
+-              brcm,pins = <9 10 11>;
+-              brcm,function = <4>; /* alt0 */
+-      };
+-
+-      spi0_cs_pins: spi0_cs_pins {
+-              brcm,pins = <8 7>;
+-              brcm,function = <1>; /* output */
+-      };
+-
+-      i2c0_pins: i2c0 {
+-              brcm,pins = <0 1>;
+-              brcm,function = <4>;
+-      };
+-
+-      i2c1_pins: i2c1 {
+-              brcm,pins = <2 3>;
+-              brcm,function = <4>;
+-      };
+-
+-      i2s_pins: i2s {
+-              brcm,pins = <18 19 20 21>;
+-              brcm,function = <4>; /* alt0 */
+-      };
+-
+-      sdio_pins: sdio_pins {
+-              brcm,pins = <34 35 36 37 38 39>;
+-              brcm,function = <7>; /* ALT3 = SD1 */
+-              brcm,pull = <0 2 2 2 2 2>;
+-      };
+-
+-      bt_pins: bt_pins {
+-              brcm,pins = <43>;
+-              brcm,function = <4>; /* alt0:GPCLK2 */
+-              brcm,pull = <0>; /* none */
+-      };
+-
+-      uart0_pins: uart0_pins {
+-              brcm,pins = <30 31 32 33>;
+-              brcm,function = <7>; /* alt3=UART0 */
+-              brcm,pull = <2 0 0 2>; /* up none none up */
+-      };
+-
+-      uart1_pins: uart1_pins {
+-              brcm,pins;
+-              brcm,function;
+-              brcm,pull;
+-      };
+-
+-      audio_pins: audio_pins {
+-              brcm,pins = <>;
+-              brcm,function = <>;
+-      };
+-};
+-
+-&mmcnr {
+-      pinctrl-names = "default";
+-      pinctrl-0 = <&sdio_pins>;
+-      bus-width = <4>;
+-      status = "okay";
+-};
+-
+-&uart0 {
+-      pinctrl-names = "default";
+-      pinctrl-0 = <&uart0_pins &bt_pins>;
+-      status = "okay";
+-};
+-
+-&uart1 {
+-      pinctrl-names = "default";
+-      pinctrl-0 = <&uart1_pins>;
+-      status = "okay";
+-};
+-
+-&spi0 {
+-      pinctrl-names = "default";
+-      pinctrl-0 = <&spi0_pins &spi0_cs_pins>;
+-      cs-gpios = <&gpio 8 1>, <&gpio 7 1>;
+-
+-      spidev0: spidev@0{
+-              compatible = "spidev";
+-              reg = <0>;      /* CE0 */
+-              #address-cells = <1>;
+-              #size-cells = <0>;
+-              spi-max-frequency = <125000000>;
+-      };
+-
+-      spidev1: spidev@1{
+-              compatible = "spidev";
+-              reg = <1>;      /* CE1 */
+-              #address-cells = <1>;
+-              #size-cells = <0>;
+-              spi-max-frequency = <125000000>;
+-      };
+-};
+-
+-&i2c0 {
+-      pinctrl-names = "default";
+-      pinctrl-0 = <&i2c0_pins>;
+-      clock-frequency = <100000>;
+-};
+-
+-&i2c1 {
+-      pinctrl-names = "default";
+-      pinctrl-0 = <&i2c1_pins>;
+-      clock-frequency = <100000>;
+-};
+-
+-&i2c2 {
+-      clock-frequency = <100000>;
+-};
+-
+-&i2s {
+-      #sound-dai-cells = <0>;
+-      pinctrl-names = "default";
+-      pinctrl-0 = <&i2s_pins>;
+-};
+-
+-&random {
+-      status = "okay";
+-};
+-
+-&leds {
+-      act_led: act {
+-              label = "led0";
+-              linux,default-trigger = "mmc0";
+-              gpios = <&gpio 47 0>;
+-      };
+-};
+-
+-&hdmi {
+-      hpd-gpios = <&gpio 46 GPIO_ACTIVE_LOW>;
+-};
+-
+-&audio {
+-      pinctrl-names = "default";
+-      pinctrl-0 = <&audio_pins>;
+-};
+-
+-/ {
+-      __overrides__ {
+-              act_led_gpio = <&act_led>,"gpios:4";
+-              act_led_activelow = <&act_led>,"gpios:8";
+-              act_led_trigger = <&act_led>,"linux,default-trigger";
+-      };
+-};
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm2708-rpi-zero-w.dts
+@@ -0,0 +1,162 @@
++/dts-v1/;
++
++#include "bcm2708.dtsi"
++#include "bcm283x-rpi-csi1-2lane.dtsi"
++
++/ {
++      compatible = "raspberrypi,model-zero-w", "brcm,bcm2835";
++      model = "Raspberry Pi Zero W";
++
++      chosen {
++              bootargs = "coherent_pool=1M 8250.nr_uarts=1";
++      };
++
++      aliases {
++              serial0 = &uart1;
++              serial1 = &uart0;
++              mmc1 = &mmcnr;
++      };
++};
++
++&gpio {
++      spi0_pins: spi0_pins {
++              brcm,pins = <9 10 11>;
++              brcm,function = <4>; /* alt0 */
++      };
++
++      spi0_cs_pins: spi0_cs_pins {
++              brcm,pins = <8 7>;
++              brcm,function = <1>; /* output */
++      };
++
++      i2c0_pins: i2c0 {
++              brcm,pins = <0 1>;
++              brcm,function = <4>;
++      };
++
++      i2c1_pins: i2c1 {
++              brcm,pins = <2 3>;
++              brcm,function = <4>;
++      };
++
++      i2s_pins: i2s {
++              brcm,pins = <18 19 20 21>;
++              brcm,function = <4>; /* alt0 */
++      };
++
++      sdio_pins: sdio_pins {
++              brcm,pins = <34 35 36 37 38 39>;
++              brcm,function = <7>; /* ALT3 = SD1 */
++              brcm,pull = <0 2 2 2 2 2>;
++      };
++
++      bt_pins: bt_pins {
++              brcm,pins = <43>;
++              brcm,function = <4>; /* alt0:GPCLK2 */
++              brcm,pull = <0>; /* none */
++      };
++
++      uart0_pins: uart0_pins {
++              brcm,pins = <30 31 32 33>;
++              brcm,function = <7>; /* alt3=UART0 */
++              brcm,pull = <2 0 0 2>; /* up none none up */
++      };
++
++      uart1_pins: uart1_pins {
++              brcm,pins;
++              brcm,function;
++              brcm,pull;
++      };
++
++      audio_pins: audio_pins {
++              brcm,pins = <>;
++              brcm,function = <>;
++      };
++};
++
++&mmcnr {
++      pinctrl-names = "default";
++      pinctrl-0 = <&sdio_pins>;
++      bus-width = <4>;
++      status = "okay";
++};
++
++&uart0 {
++      pinctrl-names = "default";
++      pinctrl-0 = <&uart0_pins &bt_pins>;
++      status = "okay";
++};
++
++&uart1 {
++      pinctrl-names = "default";
++      pinctrl-0 = <&uart1_pins>;
++      status = "okay";
++};
++
++&spi0 {
++      pinctrl-names = "default";
++      pinctrl-0 = <&spi0_pins &spi0_cs_pins>;
++      cs-gpios = <&gpio 8 1>, <&gpio 7 1>;
++
++      spidev0: spidev@0{
++              compatible = "spidev";
++              reg = <0>;      /* CE0 */
++              #address-cells = <1>;
++              #size-cells = <0>;
++              spi-max-frequency = <125000000>;
++      };
++
++      spidev1: spidev@1{
++              compatible = "spidev";
++              reg = <1>;      /* CE1 */
++              #address-cells = <1>;
++              #size-cells = <0>;
++              spi-max-frequency = <125000000>;
++      };
++};
++
++&i2c0 {
++      pinctrl-names = "default";
++      pinctrl-0 = <&i2c0_pins>;
++      clock-frequency = <100000>;
++};
++
++&i2c1 {
++      pinctrl-names = "default";
++      pinctrl-0 = <&i2c1_pins>;
++      clock-frequency = <100000>;
++};
++
++&i2c2 {
++      clock-frequency = <100000>;
++};
++
++&i2s {
++      pinctrl-names = "default";
++      pinctrl-0 = <&i2s_pins>;
++};
++
++&leds {
++      act_led: act {
++              label = "led0";
++              linux,default-trigger = "mmc0";
++              gpios = <&gpio 47 0>;
++      };
++};
++
++&hdmi {
++      hpd-gpios = <&gpio 46 GPIO_ACTIVE_LOW>;
++};
++
++&audio {
++      pinctrl-names = "default";
++      pinctrl-0 = <&audio_pins>;
++};
++
++/ {
++      __overrides__ {
++              act_led_gpio = <&act_led>,"gpios:4";
++              act_led_activelow = <&act_led>,"gpios:8";
++              act_led_trigger = <&act_led>,"linux,default-trigger";
++      };
++};