brcm63xx: register serial through device tree
[openwrt/openwrt.git] / target / linux / brcm63xx / patches-4.4 / 422-BCM63XX-add-a-fixup-for-rt2x00-devices.patch
index 5731cb34aa80681b443ec8b5c7382a62f2603098..d021b369046a6c37686bc61b7f8327f9dd86d142 100644 (file)
@@ -19,7 +19,7 @@ Subject: [PATCH 72/72] 446-BCM63XX-add-a-fixup-for-rt2x00-devices
 +++ b/arch/mips/bcm63xx/Makefile
 @@ -2,7 +2,7 @@ obj-y          += clk.o cpu.o cs.o gpio.o irq.o
                   setup.o timer.o dev-dsp.o dev-enet.o dev-flash.o \
-                  dev-pcmcia.o dev-rng.o dev-spi.o dev-hsspi.o dev-uart.o \
+                  dev-pcmcia.o dev-rng.o \
                   dev-wdt.o dev-usb-ehci.o dev-usb-ohci.o dev-usb-usbd.o \
 -                 pci-ath9k-fixup.o usb-common.o sprom.o
 +                 pci-ath9k-fixup.o pci-rt2x00-fixup.o usb-common.o sprom.o
@@ -28,7 +28,7 @@ Subject: [PATCH 72/72] 446-BCM63XX-add-a-fixup-for-rt2x00-devices
  obj-y         += boards/
 --- a/arch/mips/bcm63xx/boards/board_common.c
 +++ b/arch/mips/bcm63xx/boards/board_common.c
-@@ -34,6 +34,7 @@
+@@ -33,6 +33,7 @@
  #include <bcm63xx_dev_usb_usbd.h>
  #include <board_bcm963xx.h>
  #include <pci_ath9k_fixup.h>
@@ -36,7 +36,7 @@ Subject: [PATCH 72/72] 446-BCM63XX-add-a-fixup-for-rt2x00-devices
  
  #include "board_common.h"
  
-@@ -255,9 +256,19 @@ int __init board_register_devices(void)
+@@ -248,9 +249,19 @@ int __init board_register_devices(void)
        }
  
        /* register any fixups */
@@ -162,7 +162,7 @@ Subject: [PATCH 72/72] 446-BCM63XX-add-a-fixup-for-rt2x00-devices
  };
  
  /*
-@@ -48,7 +53,7 @@ struct board_info {
+@@ -46,7 +51,7 @@ struct board_info {
        unsigned int    has_caldata:2;
  
        /* wifi calibration data config */