"default-on" LED Trigger
[openwrt/openwrt.git] / target / linux / generic-2.6 / patches-2.6.23 / 402-ledtrig_default_on.patch
diff --git a/target/linux/generic-2.6/patches-2.6.23/402-ledtrig_default_on.patch b/target/linux/generic-2.6/patches-2.6.23/402-ledtrig_default_on.patch
new file mode 100644 (file)
index 0000000..a59915c
--- /dev/null
@@ -0,0 +1,23 @@
+diff -ur linux-2.6.23.1.orig/drivers/leds/Kconfig linux-2.6.23.1/drivers/leds/Kconfig
+--- linux-2.6.23.1.orig/drivers/leds/Kconfig   2007-12-01 00:41:03.000000000 +1300
++++ linux-2.6.23.1/drivers/leds/Kconfig        2007-12-01 01:26:43.000000000 +1300
+@@ -137,4 +137,11 @@
+       tristate "LED Morse Trigger"
+       depends on LEDS_TRIGGERS
++config LEDS_TRIGGER_DEFAULT_ON
++      tristate "LED Default ON Trigger"
++      depends on LEDS_TRIGGERS
++      help
++        This allows LEDs to be initialised in the ON state.
++        If unsure, say Y.
++
+ endif # NEW_LEDS
+diff -ur linux-2.6.23.1.orig/drivers/leds/Makefile linux-2.6.23.1/drivers/leds/Makefile
+--- linux-2.6.23.1.orig/drivers/leds/Makefile  2007-12-01 00:41:03.000000000 +1300
++++ linux-2.6.23.1/drivers/leds/Makefile       2007-12-01 01:27:12.000000000 +1300
+@@ -23,3 +23,4 @@
+ obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK)   += ledtrig-ide-disk.o
+ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT)  += ledtrig-heartbeat.o
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE)      += ledtrig-morse.o
++obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o