refresh generic 2.6.23 patches in upstream style
[openwrt/openwrt.git] / target / linux / generic-2.6 / patches-2.6.23 / 902-darwin_scripts_include.patch
index 173a305b2227a4d8432d644a93e6b31776e93c25..9bf058bc74c140a0228db3ee1253174480ea4200 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.23.17/scripts/genksyms/parse.c_shipped
-===================================================================
---- linux-2.6.23.17.orig/scripts/genksyms/parse.c_shipped
-+++ linux-2.6.23.17/scripts/genksyms/parse.c_shipped
+--- a/scripts/genksyms/parse.c_shipped
++++ b/scripts/genksyms/parse.c_shipped
 @@ -144,7 +144,9 @@
  
  
@@ -12,10 +10,8 @@ Index: linux-2.6.23.17/scripts/genksyms/parse.c_shipped
  #include "genksyms.h"
  
  static int is_typedef;
-Index: linux-2.6.23.17/scripts/genksyms/parse.y
-===================================================================
---- linux-2.6.23.17.orig/scripts/genksyms/parse.y
-+++ linux-2.6.23.17/scripts/genksyms/parse.y
+--- a/scripts/genksyms/parse.y
++++ b/scripts/genksyms/parse.y
 @@ -24,7 +24,9 @@
  %{
  
@@ -26,10 +22,8 @@ Index: linux-2.6.23.17/scripts/genksyms/parse.y
  #include "genksyms.h"
  
  static int is_typedef;
-Index: linux-2.6.23.17/scripts/kallsyms.c
-===================================================================
---- linux-2.6.23.17.orig/scripts/kallsyms.c
-+++ linux-2.6.23.17/scripts/kallsyms.c
+--- a/scripts/kallsyms.c
++++ b/scripts/kallsyms.c
 @@ -28,6 +28,35 @@
  #include <stdlib.h>
  #include <string.h>
@@ -66,11 +60,9 @@ Index: linux-2.6.23.17/scripts/kallsyms.c
  
  #define KSYM_NAME_LEN         128
  
-Index: linux-2.6.23.17/scripts/kconfig/Makefile
-===================================================================
---- linux-2.6.23.17.orig/scripts/kconfig/Makefile
-+++ linux-2.6.23.17/scripts/kconfig/Makefile
-@@ -88,6 +88,9 @@ check-lxdialog  := $(srctree)/$(src)/lxd
+--- a/scripts/kconfig/Makefile
++++ b/scripts/kconfig/Makefile
+@@ -88,6 +88,9 @@
  # we really need to do so. (Do not call gcc as part of make mrproper)
  HOST_EXTRACFLAGS = $(shell $(CONFIG_SHELL) $(check-lxdialog) -ccflags)
  HOST_LOADLIBES   = $(shell $(CONFIG_SHELL) $(check-lxdialog) -ldflags $(HOSTCC))
@@ -80,10 +72,8 @@ Index: linux-2.6.23.17/scripts/kconfig/Makefile
  
  HOST_EXTRACFLAGS += -DLOCALE
  
-Index: linux-2.6.23.17/scripts/mod/mk_elfconfig.c
-===================================================================
---- linux-2.6.23.17.orig/scripts/mod/mk_elfconfig.c
-+++ linux-2.6.23.17/scripts/mod/mk_elfconfig.c
+--- a/scripts/mod/mk_elfconfig.c
++++ b/scripts/mod/mk_elfconfig.c
 @@ -1,7 +1,11 @@
  #include <stdio.h>
  #include <stdlib.h>
@@ -96,10 +86,8 @@ Index: linux-2.6.23.17/scripts/mod/mk_elfconfig.c
  
  int
  main(int argc, char **argv)
-Index: linux-2.6.23.17/scripts/mod/modpost.h
-===================================================================
---- linux-2.6.23.17.orig/scripts/mod/modpost.h
-+++ linux-2.6.23.17/scripts/mod/modpost.h
+--- a/scripts/mod/modpost.h
++++ b/scripts/mod/modpost.h
 @@ -7,7 +7,11 @@
  #include <sys/mman.h>
  #include <fcntl.h>