rename target/linux/generic-2.6 to generic
[openwrt/openwrt.git] / target / linux / generic-2.6 / patches-2.6.25 / 410-gpio_buttons.patch
diff --git a/target/linux/generic-2.6/patches-2.6.25/410-gpio_buttons.patch b/target/linux/generic-2.6/patches-2.6.25/410-gpio_buttons.patch
deleted file mode 100644 (file)
index 46ca987..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/drivers/input/misc/Kconfig
-+++ b/drivers/input/misc/Kconfig
-@@ -197,4 +197,20 @@ config HP_SDC_RTC
-         Say Y here if you want to support the built-in real time clock
-         of the HP SDC controller.
-+config INPUT_GPIO_BUTTONS
-+      tristate "Polled GPIO buttons interface"
-+      depends on GENERIC_GPIO
-+      select INPUT_POLLDEV
-+      help
-+        This driver implements support for buttons connected
-+        to GPIO pins of various CPUs (and some other chips).
-+
-+        Say Y here if your device has buttons connected
-+        directly to such GPIO pins.  Your board-specific
-+        setup logic must also provide a platform device,
-+        with configuration data saying which GPIOs are used.
-+
-+        To compile this driver as a module, choose M here: the
-+        module will be called gpio-buttons.
-+
- endif
---- a/drivers/input/misc/Makefile
-+++ b/drivers/input/misc/Makefile
-@@ -19,3 +19,4 @@ obj-$(CONFIG_INPUT_YEALINK)          += yealink.
- obj-$(CONFIG_HP_SDC_RTC)              += hp_sdc_rtc.o
- obj-$(CONFIG_INPUT_UINPUT)            += uinput.o
- obj-$(CONFIG_INPUT_APANEL)            += apanel.o
-+obj-$(CONFIG_INPUT_GPIO_BUTTONS)      += gpio_buttons.o