Remove me from the gpio-spi related stuff
[openwrt/openwrt.git] / target / linux / generic-2.6 / patches-2.6.25 / 921-gpio_spi_driver.patch
index 4608a222d98619a0ab1ec7bfb4a5fd431efe67a3..760d27aedaffc2dad22bec58788f06bf7d5dd8c7 100644 (file)
@@ -1,11 +1,12 @@
---- /dev/null
-+++ b/include/linux/spi/spi_gpio.h
-@@ -0,0 +1,73 @@
+Index: linux-2.6.25.17/include/linux/spi/spi_gpio.h
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ linux-2.6.25.17/include/linux/spi/spi_gpio.h       2008-10-18 23:32:31.000000000 +0200
+@@ -0,0 +1,72 @@
 +/*
 + * spi_gpio interface to platform code
 + *
 + * Copyright (c) 2008 Piotr Skamruk
 +/*
 + * spi_gpio interface to platform code
 + *
 + * Copyright (c) 2008 Piotr Skamruk
-+ * Copyright (c) 2008 Michael Buesch
 + *
 + * This program is free software; you can redistribute it and/or modify
 + * it under the terms of the GNU General Public License version 2 as
 + *
 + * This program is free software; you can redistribute it and/or modify
 + * it under the terms of the GNU General Public License version 2 as
 +int spi_gpio_next_id(void);
 +
 +#endif /* _LINUX_SPI_SPI_GPIO */
 +int spi_gpio_next_id(void);
 +
 +#endif /* _LINUX_SPI_SPI_GPIO */
---- /dev/null
-+++ b/drivers/spi/spi_gpio.c
-@@ -0,0 +1,251 @@
+Index: linux-2.6.25.17/drivers/spi/spi_gpio.c
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ linux-2.6.25.17/drivers/spi/spi_gpio.c     2008-10-18 23:31:27.000000000 +0200
+@@ -0,0 +1,249 @@
 +/*
 + * Bitbanging SPI bus driver using GPIO API
 + *
 + * Copyright (c) 2008 Piotr Skamruk
 +/*
 + * Bitbanging SPI bus driver using GPIO API
 + *
 + * Copyright (c) 2008 Piotr Skamruk
-+ * Copyright (c) 2008 Michael Buesch
 + *
 + * based on spi_s3c2410_gpio.c
 + *   Copyright (c) 2006 Ben Dooks
 + *
 + * based on spi_s3c2410_gpio.c
 + *   Copyright (c) 2006 Ben Dooks
 +module_exit(spi_gpio_exit);
 +
 +MODULE_AUTHOR("Piot Skamruk <piotr.skamruk at gmail.com>");
 +module_exit(spi_gpio_exit);
 +
 +MODULE_AUTHOR("Piot Skamruk <piotr.skamruk at gmail.com>");
-+MODULE_AUTHOR("Michael Buesch");
 +MODULE_DESCRIPTION("Platform independent GPIO bitbanging SPI driver");
 +MODULE_LICENSE("GPL v2");
 +MODULE_DESCRIPTION("Platform independent GPIO bitbanging SPI driver");
 +MODULE_LICENSE("GPL v2");
---- a/drivers/spi/Kconfig
-+++ b/drivers/spi/Kconfig
-@@ -100,6 +100,19 @@
+Index: linux-2.6.25.17/drivers/spi/Kconfig
+===================================================================
+--- linux-2.6.25.17.orig/drivers/spi/Kconfig   2008-10-18 23:30:41.000000000 +0200
++++ linux-2.6.25.17/drivers/spi/Kconfig        2008-10-18 23:30:43.000000000 +0200
+@@ -100,6 +100,19 @@ config SPI_BUTTERFLY
          inexpensive battery powered microcontroller evaluation board.
          This same cable can be used to flash new firmware.
  
          inexpensive battery powered microcontroller evaluation board.
          This same cable can be used to flash new firmware.
  
  config SPI_IMX
        tristate "Freescale iMX SPI controller"
        depends on SPI_MASTER && ARCH_IMX && EXPERIMENTAL
  config SPI_IMX
        tristate "Freescale iMX SPI controller"
        depends on SPI_MASTER && ARCH_IMX && EXPERIMENTAL
---- a/drivers/spi/Makefile
-+++ b/drivers/spi/Makefile
-@@ -16,6 +16,7 @@
+Index: linux-2.6.25.17/drivers/spi/Makefile
+===================================================================
+--- linux-2.6.25.17.orig/drivers/spi/Makefile  2008-10-18 23:30:41.000000000 +0200
++++ linux-2.6.25.17/drivers/spi/Makefile       2008-10-18 23:30:43.000000000 +0200
+@@ -16,6 +16,7 @@ obj-$(CONFIG_SPI_BFIN)                       += spi_bfin5xx.
  obj-$(CONFIG_SPI_BITBANG)             += spi_bitbang.o
  obj-$(CONFIG_SPI_AU1550)              += au1550_spi.o
  obj-$(CONFIG_SPI_BUTTERFLY)           += spi_butterfly.o
  obj-$(CONFIG_SPI_BITBANG)             += spi_bitbang.o
  obj-$(CONFIG_SPI_AU1550)              += au1550_spi.o
  obj-$(CONFIG_SPI_BUTTERFLY)           += spi_butterfly.o
  obj-$(CONFIG_SPI_IMX)                 += spi_imx.o
  obj-$(CONFIG_SPI_LM70_LLP)            += spi_lm70llp.o
  obj-$(CONFIG_SPI_PXA2XX)              += pxa2xx_spi.o
  obj-$(CONFIG_SPI_IMX)                 += spi_imx.o
  obj-$(CONFIG_SPI_LM70_LLP)            += spi_lm70llp.o
  obj-$(CONFIG_SPI_PXA2XX)              += pxa2xx_spi.o
---- a/MAINTAINERS
-+++ b/MAINTAINERS
-@@ -3685,6 +3685,11 @@
- L:    spi-devel-general@lists.sourceforge.net
- S:    Maintained
-+SPI GPIO MASTER DRIVER
-+P:    Michael Buesch
-+M:    mb@bu3sch.de
-+S:    Maintained
-+
- STABLE BRANCH:
- P:    Greg Kroah-Hartman
- M:    greg@kroah.com