rename target/linux/generic-2.6 to generic
[openwrt/openwrt.git] / target / linux / generic-2.6 / patches-2.6.32 / 691-phy_rtl8366.patch
diff --git a/target/linux/generic-2.6/patches-2.6.32/691-phy_rtl8366.patch b/target/linux/generic-2.6/patches-2.6.32/691-phy_rtl8366.patch
deleted file mode 100644 (file)
index 5605091..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -141,4 +141,29 @@ config MDIO_GPIO
-         To compile this driver as a module, choose M here: the module
-         will be called mdio-gpio.
-+config RTL8366_SMI
-+      tristate "Driver for the RTL8366 SMI interface"
-+      depends on GENERIC_GPIO
-+      ---help---
-+        This module implements the SMI interface protocol which is used
-+        by some RTL8366 ethernet switch devices via the generic GPIO API.
-+
-+if RTL8366_SMI
-+
-+config RTL8366S_PHY
-+      tristate "Driver for the Realtek RTL8366S switch"
-+      select SWCONFIG
-+
-+config RTL8366RB_PHY
-+      tristate "Driver for the Realtek RTL8366RB switch"
-+      select SWCONFIG
-+
-+config RTL8366S_PHY_DEBUG_FS
-+      bool "RTL8366 switch driver DEBUG_FS support"
-+      depends on RTL8366S_PHY || RTL8366RB_PHY
-+      depends on DEBUG_FS
-+      default n
-+
-+endif # RTL8366_SMI
-+
- endif # PHYLIB
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -20,6 +20,9 @@ obj-$(CONFIG_IP17XX_PHY)     += ip17xx.o
- obj-$(CONFIG_REALTEK_PHY)     += realtek.o
- obj-$(CONFIG_AR8216_PHY)      += ar8216.o
- obj-$(CONFIG_RTL8306_PHY)     += rtl8306.o
-+obj-$(CONFIG_RTL8366_SMI)     += rtl8366_smi.o
-+obj-$(CONFIG_RTL8366S_PHY)    += rtl8366s.o
-+obj-$(CONFIG_RTL8366RB_PHY)   += rtl8366rb.o
- obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
- obj-$(CONFIG_FIXED_PHY)               += fixed.o
- obj-$(CONFIG_MDIO_BITBANG)    += mdio-bitbang.o