rename target/linux/generic-2.6 to generic
[openwrt/openwrt.git] / target / linux / generic-2.6 / patches-2.6.34 / 420-gpiodev.patch
diff --git a/target/linux/generic-2.6/patches-2.6.34/420-gpiodev.patch b/target/linux/generic-2.6/patches-2.6.34/420-gpiodev.patch
deleted file mode 100644 (file)
index 27da3c7..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/drivers/char/Kconfig
-+++ b/drivers/char/Kconfig
-@@ -1024,6 +1024,14 @@ config CS5535_GPIO
-         If compiled as a module, it will be called cs5535_gpio.
-+config GPIO_DEVICE
-+      tristate "GPIO device support"
-+      depends on GENERIC_GPIO
-+      help
-+        Say Y to enable Linux GPIO device support.  This allows control of
-+        GPIO pins using a character device
-+
-+
- config RAW_DRIVER
-       tristate "RAW driver (/dev/raw/rawN)"
-       depends on BLOCK
---- a/drivers/char/Makefile
-+++ b/drivers/char/Makefile
-@@ -95,6 +95,7 @@ obj-$(CONFIG_SCx200_GPIO)    += scx200_gpio
- obj-$(CONFIG_PC8736x_GPIO)    += pc8736x_gpio.o
- obj-$(CONFIG_NSC_GPIO)                += nsc_gpio.o
- obj-$(CONFIG_CS5535_GPIO)     += cs5535_gpio.o
-+obj-$(CONFIG_GPIO_DEVICE)     += gpio_dev.o
- obj-$(CONFIG_GPIO_TB0219)     += tb0219.o
- obj-$(CONFIG_TELCLOCK)                += tlclk.o