generic-2.6: add kernel 2.6.35 preliminary support (patches)
[openwrt/openwrt.git] / target / linux / generic-2.6 / patches-2.6.35 / 690-phy_rtl8306.patch
diff --git a/target/linux/generic-2.6/patches-2.6.35/690-phy_rtl8306.patch b/target/linux/generic-2.6/patches-2.6.35/690-phy_rtl8306.patch
new file mode 100644 (file)
index 0000000..9e86748
--- /dev/null
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -115,6 +115,10 @@ config AR8216_PHY
+       tristate "Driver for Atheros AR8216 switches"
+       select SWCONFIG
++config RTL8306_PHY
++      tristate "Driver for Realtek RTL8306S switches"
++      select SWCONFIG
++
+ config FIXED_PHY
+       bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+       depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -19,6 +19,7 @@ obj-$(CONFIG_MVSWITCH_PHY)   += mvswitch.o
+ obj-$(CONFIG_IP175C_PHY)      += ip175c.o
+ obj-$(CONFIG_REALTEK_PHY)     += realtek.o
+ obj-$(CONFIG_AR8216_PHY)      += ar8216.o
++obj-$(CONFIG_RTL8306_PHY)     += rtl8306.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY)               += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG)    += mdio-bitbang.o