kernel: backport a rewrite of the mips eBPF JIT implementation
[openwrt/openwrt.git] / target / linux / generic / backport-5.4 / 071-v5.16-05-mips-bpf-Enable-eBPF-JITs.patch
diff --git a/target/linux/generic/backport-5.4/071-v5.16-05-mips-bpf-Enable-eBPF-JITs.patch b/target/linux/generic/backport-5.4/071-v5.16-05-mips-bpf-Enable-eBPF-JITs.patch
new file mode 100644 (file)
index 0000000..c8ce0be
--- /dev/null
@@ -0,0 +1,54 @@
+From: Johan Almbladh <johan.almbladh@anyfinetworks.com>
+Date: Tue, 5 Oct 2021 18:54:07 +0200
+Subject: [PATCH] mips: bpf: Enable eBPF JITs
+
+This patch enables the new eBPF JITs for 32-bit and 64-bit MIPS. It also
+disables the old cBPF JIT to so cBPF programs are converted to use the
+new JIT.
+
+Workarounds for R4000 CPU errata are not implemented by the JIT, so the
+JIT is disabled if any of those workarounds are configured.
+
+Signed-off-by: Johan Almbladh <johan.almbladh@anyfinetworks.com>
+---
+
+--- a/MAINTAINERS
++++ b/MAINTAINERS
+@@ -3099,6 +3099,7 @@ S:       Supported
+ F:    arch/arm64/net/
+ BPF JIT for MIPS (32-BIT AND 64-BIT)
++M:    Johan Almbladh <johan.almbladh@anyfinetworks.com>
+ M:    Paul Burton <paulburton@kernel.org>
+ L:    netdev@vger.kernel.org
+ L:    bpf@vger.kernel.org
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -46,8 +46,10 @@ config MIPS
+       select HAVE_ARCH_TRACEHOOK
+       select HAVE_ARCH_TRANSPARENT_HUGEPAGE if CPU_SUPPORTS_HUGEPAGES
+       select HAVE_ASM_MODVERSIONS
+-      select HAVE_CBPF_JIT if !64BIT && !CPU_MICROMIPS
+-      select HAVE_EBPF_JIT if 64BIT && !CPU_MICROMIPS && TARGET_ISA_REV >= 2
++      select HAVE_EBPF_JIT if !CPU_MICROMIPS && \
++                              !CPU_DADDI_WORKAROUNDS && \
++                              !CPU_R4000_WORKAROUNDS && \
++                              !CPU_R4400_WORKAROUNDS
+       select HAVE_CONTEXT_TRACKING
+       select HAVE_COPY_THREAD_TLS
+       select HAVE_C_RECORDMCOUNT
+--- a/arch/mips/net/Makefile
++++ b/arch/mips/net/Makefile
+@@ -2,9 +2,10 @@
+ # MIPS networking code
+ obj-$(CONFIG_MIPS_CBPF_JIT) += bpf_jit.o bpf_jit_asm.o
++obj-$(CONFIG_MIPS_EBPF_JIT) += bpf_jit_comp.o
+ ifeq ($(CONFIG_32BIT),y)
+-        obj-$(CONFIG_MIPS_EBPF_JIT) += bpf_jit_comp.o bpf_jit_comp32.o
++        obj-$(CONFIG_MIPS_EBPF_JIT) += bpf_jit_comp32.o
+ else
+-        obj-$(CONFIG_MIPS_EBPF_JIT) += ebpf_jit.o
++        obj-$(CONFIG_MIPS_EBPF_JIT) += bpf_jit_comp64.o
+ endif