kernel: update 4.9 to 4.9.44
[openwrt/openwrt.git] / target / linux / generic / hack-4.9 / 230-openwrt_lzma_options.patch
index d20f3aa6930464054c550fbca19fb3b488e9a667..b3c444265d3078efaa13530fe5aeaf1445efbd10 100644 (file)
@@ -11,11 +11,9 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
  scripts/gen_initramfs_list.sh | 10 +++++-----
  3 files changed, 7 insertions(+), 6 deletions(-)
 
-diff --git a/lib/decompress.c b/lib/decompress.c
-index 62696dff5730..d91a26e1a1b2 100644
 --- a/lib/decompress.c
 +++ b/lib/decompress.c
-@@ -48,6 +48,7 @@ static const struct compress_format compressed_formats[] __initconst = {
+@@ -48,6 +48,7 @@ static const struct compress_format comp
        { {0x1f, 0x9e}, "gzip", gunzip },
        { {0x42, 0x5a}, "bzip2", bunzip2 },
        { {0x5d, 0x00}, "lzma", unlzma },
@@ -23,11 +21,9 @@ index 62696dff5730..d91a26e1a1b2 100644
        { {0xfd, 0x37}, "xz", unxz },
        { {0x89, 0x4c}, "lzo", unlzo },
        { {0x02, 0x21}, "lz4", unlz4 },
-diff --git a/scripts/Makefile.lib b/scripts/Makefile.lib
-index 0a07f9014944..5324c072c598 100644
 --- a/scripts/Makefile.lib
 +++ b/scripts/Makefile.lib
-@@ -344,7 +344,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^) | \
+@@ -344,7 +344,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
  
  quiet_cmd_lzma = LZMA    $@
  cmd_lzma = (cat $(filter-out FORCE,$^) | \
@@ -36,8 +32,6 @@ index 0a07f9014944..5324c072c598 100644
        (rm -f $@ ; false)
  
  quiet_cmd_lzo = LZO     $@
-diff --git a/scripts/gen_initramfs_list.sh b/scripts/gen_initramfs_list.sh
-index 0055b07b03b6..7710113e6a72 100755
 --- a/scripts/gen_initramfs_list.sh
 +++ b/scripts/gen_initramfs_list.sh
 @@ -229,7 +229,7 @@ cpio_list=
@@ -75,6 +69,3 @@ index 0055b07b03b6..7710113e6a72 100755
                || (rm -f ${output_file} ; false)
        fi
        [ -z ${cpio_file} ] && rm ${cpio_tfile}
--- 
-2.11.0
-