generic: fix relocate build with binutils 2.25.1
[openwrt/openwrt.git] / target / linux / generic / image / relocate / Makefile
index 5f6ebeb096b6dd1ce14a591c619f8c9b617ec0e8..19e701968f447748be5ce4be26941df7fb94bc10 100644 (file)
@@ -29,7 +29,8 @@ LD            := $(CROSS_COMPILE)ld
 OBJCOPY                := $(CROSS_COMPILE)objcopy
 OBJDUMP                := $(CROSS_COMPILE)objdump
 
-BIN_FLAGS      := -O binary -R .reginfo -R .note -R .comment -R .mdebug -S
+BIN_FLAGS      := -O binary -R .reginfo -R .note -R .comment -R .mdebug \
+                  -R .MIPS.abiflags -S
 
 CFLAGS         = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
                  -fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 \