kernel: split patches folder up into backport, pending and hack folders
[openwrt/openwrt.git] / target / linux / generic / pending-3.18 / 831-ledtrig_netdev.patch
diff --git a/target/linux/generic/pending-3.18/831-ledtrig_netdev.patch b/target/linux/generic/pending-3.18/831-ledtrig_netdev.patch
new file mode 100644 (file)
index 0000000..3b46b4a
--- /dev/null
@@ -0,0 +1,21 @@
+--- a/drivers/leds/trigger/Kconfig
++++ b/drivers/leds/trigger/Kconfig
+@@ -108,4 +108,11 @@ config LEDS_TRIGGER_CAMERA
+         This enables direct flash/torch on/off by the driver, kernel space.
+         If unsure, say Y.
++config LEDS_TRIGGER_NETDEV
++      tristate "LED Netdev Trigger"
++      depends on NET && LEDS_TRIGGERS
++      help
++        This allows LEDs to be controlled by network device activity.
++        If unsure, say Y.
++
+ endif # LEDS_TRIGGERS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -62,3 +62,4 @@ obj-$(CONFIG_LEDS_DAC124S085)                += leds-d
+ # LED Triggers
+ obj-$(CONFIG_LEDS_TRIGGERS)           += trigger/
++obj-$(CONFIG_LEDS_TRIGGER_NETDEV)     += ledtrig-netdev.o