kernel: bump 4.19 to 4.19.115
[openwrt/openwrt.git] / target / linux / imx6 / patches-4.19 / 003-ARM-dts-imx-Add-GW5913-board-support.patch
index 2d242fb890e5d83dd87462feac7049dd11ffd284..9c46401201d06bc7a16f4f2586ceabe756774131 100644 (file)
@@ -30,11 +30,9 @@ Signed-off-by: Shawn Guo <shawnguo@kernel.org>
  create mode 100644 arch/arm/boot/dts/imx6q-gw5913.dts
  create mode 100644 arch/arm/boot/dts/imx6qdl-gw5913.dtsi
 
-diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
-index 85e53cc..5b059fc 100644
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -424,6 +424,7 @@ dtb-$(CONFIG_SOC_IMX6Q) += \
+@@ -406,6 +406,7 @@ dtb-$(CONFIG_SOC_IMX6Q) += \
        imx6dl-gw5904.dtb \
        imx6dl-gw5907.dtb \
        imx6dl-gw5910.dtb \
@@ -42,7 +40,7 @@ index 85e53cc..5b059fc 100644
        imx6dl-hummingboard.dtb \
        imx6dl-hummingboard-emmc-som-v15.dtb \
        imx6dl-hummingboard-som-v15.dtb \
-@@ -497,6 +498,7 @@ dtb-$(CONFIG_SOC_IMX6Q) += \
+@@ -475,6 +476,7 @@ dtb-$(CONFIG_SOC_IMX6Q) += \
        imx6q-gw5904.dtb \
        imx6q-gw5907.dtb \
        imx6q-gw5910.dtb \
@@ -50,9 +48,6 @@ index 85e53cc..5b059fc 100644
        imx6q-h100.dtb \
        imx6q-hummingboard.dtb \
        imx6q-hummingboard-emmc-som-v15.dtb \
-diff --git a/arch/arm/boot/dts/imx6dl-gw5913.dts b/arch/arm/boot/dts/imx6dl-gw5913.dts
-new file mode 100644
-index 00000000..b74e533
 --- /dev/null
 +++ b/arch/arm/boot/dts/imx6dl-gw5913.dts
 @@ -0,0 +1,14 @@
@@ -70,9 +65,6 @@ index 00000000..b74e533
 +      model = "Gateworks Ventana i.MX6 DualLite/Solo GW5913";
 +      compatible = "gw,imx6dl-gw5913", "gw,ventana", "fsl,imx6dl";
 +};
-diff --git a/arch/arm/boot/dts/imx6q-gw5913.dts b/arch/arm/boot/dts/imx6q-gw5913.dts
-new file mode 100644
-index 00000000..6f511f1
 --- /dev/null
 +++ b/arch/arm/boot/dts/imx6q-gw5913.dts
 @@ -0,0 +1,14 @@
@@ -90,9 +82,6 @@ index 00000000..6f511f1
 +      model = "Gateworks Ventana i.MX6 Dual/Quad GW5913";
 +      compatible = "gw,imx6q-gw5913", "gw,ventana", "fsl,imx6q";
 +};
-diff --git a/arch/arm/boot/dts/imx6qdl-gw5913.dtsi b/arch/arm/boot/dts/imx6qdl-gw5913.dtsi
-new file mode 100644
-index 00000000..635c203
 --- /dev/null
 +++ b/arch/arm/boot/dts/imx6qdl-gw5913.dtsi
 @@ -0,0 +1,348 @@
@@ -444,6 +433,3 @@ index 00000000..635c203
 +              >;
 +      };
 +};
--- 
-2.7.4
-