imx6: reorganize build system
[openwrt/openwrt.git] / target / linux / imx6 / profiles / 100-generic.mk
diff --git a/target/linux/imx6/profiles/100-generic.mk b/target/linux/imx6/profiles/100-generic.mk
new file mode 100644 (file)
index 0000000..91ca369
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+  NAME:=Generic (default)
+  PACKAGES:= \
+       kmod-thermal-imx kmod-usb-chipidea kmod-usb-mxs-phy \
+       uboot-envtools
+endef
+
+define Profile/Generic/Description
+ Package set compatible with most Freescale i.MX 6 based boards.
+endef
+
+$(eval $(call Profile,Generic))