ipq40xx: add support for Plasma Cloud PA1200
[openwrt/openwrt.git] / target / linux / ipq40xx / image / Makefile
index b3f2d1f755f61ac176dddfad785d59eee09d6c61..b0fde22813010c866dad7995eb6587532e2d8f8b 100644 (file)
@@ -648,6 +648,22 @@ define Device/openmesh_a62
 endef
 TARGET_DEVICES += openmesh_a62
 
+define Device/plasmacloud_pa1200
+       $(call Device/FitImageLzma)
+       DEVICE_VENDOR := Plasma Cloud
+       DEVICE_MODEL := PA1200
+       SOC := qcom-ipq4018
+       DEVICE_DTS_CONFIG := config@pc.pa1200
+       BLOCKSIZE := 64k
+       KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb | pad-to $$(BLOCKSIZE)
+       IMAGE_SIZE := 15616k
+       IMAGES += factory.bin
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=PA1200
+       IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
+       DEVICE_PACKAGES := uboot-envtools ipq-wifi-plasmacloud-pa1200
+endef
+TARGET_DEVICES += plasmacloud_pa1200
+
 define Device/qcom_ap-dk01.1-c1
        DEVICE_VENDOR := Qualcomm Atheros
        DEVICE_MODEL := AP-DK01.1