ipq40xx: remove support for kernel 4.19
[openwrt/openwrt.git] / target / linux / ipq40xx / patches-4.19 / 088-v5.6-regulator-add-IPQ4019-SDHCI-VQMMC-LDO-driver.patch
diff --git a/target/linux/ipq40xx/patches-4.19/088-v5.6-regulator-add-IPQ4019-SDHCI-VQMMC-LDO-driver.patch b/target/linux/ipq40xx/patches-4.19/088-v5.6-regulator-add-IPQ4019-SDHCI-VQMMC-LDO-driver.patch
deleted file mode 100644 (file)
index 6b46cda..0000000
+++ /dev/null
@@ -1,153 +0,0 @@
-From 97043d292365ae39d62b54a6d79dff98d048b501 Mon Sep 17 00:00:00 2001
-From: Robert Marko <robert.marko@sartura.hr>
-Date: Wed, 22 Jan 2020 12:44:14 +0100
-Subject: [PATCH] From ebf652b408200504194be32ad0a3f5bb49d6000a Mon Sep 17
- 00:00:00 2001 From: Robert Marko <robert.marko@sartura.hr> Date: Sun, 12 Jan
- 2020 12:30:01 +0100 Subject: [PATCH] regulator: add IPQ4019 SDHCI VQMMC LDO
- driver
-
-This introduces the IPQ4019 VQMMC LDO driver needed for
-the SD/EMMC driver I/O level operation.
-This will enable introducing SD/EMMC support for the built-in controller.
-
-Signed-off-by: Mantas Pucka <mantas@8devices.com>
-Signed-off-by: Robert Marko <robert.marko@sartura.hr>
-Link: https://lore.kernel.org/r/20200112113003.11110-1-robert.marko@sartura.hr
-Signed-off-by: Mark Brown <broonie@kernel.org>
----
- drivers/regulator/Kconfig                   |   7 ++
- drivers/regulator/Makefile                  |   1 +
- drivers/regulator/vqmmc-ipq4019-regulator.c | 101 ++++++++++++++++++++
- 3 files changed, 109 insertions(+)
- create mode 100644 drivers/regulator/vqmmc-ipq4019-regulator.c
-
---- a/drivers/regulator/Kconfig
-+++ b/drivers/regulator/Kconfig
-@@ -981,6 +981,13 @@ config REGULATOR_VEXPRESS
-         This driver provides support for voltage regulators available
-         on the ARM Ltd's Versatile Express platform.
-+config REGULATOR_VQMMC_IPQ4019
-+      tristate "IPQ4019 VQMMC SD LDO regulator support"
-+      depends on ARCH_QCOM
-+      help
-+        This driver provides support for the VQMMC LDO I/0
-+        voltage regulator of the IPQ4019 SD/EMMC controller.
-+
- config REGULATOR_WM831X
-       tristate "Wolfson Microelectronics WM831x PMIC regulators"
-       depends on MFD_WM831X
---- a/drivers/regulator/Makefile
-+++ b/drivers/regulator/Makefile
-@@ -122,6 +122,7 @@ obj-$(CONFIG_REGULATOR_TWL4030) += twl-r
- obj-$(CONFIG_REGULATOR_UNIPHIER) += uniphier-regulator.o
- obj-$(CONFIG_REGULATOR_VCTRL) += vctrl-regulator.o
- obj-$(CONFIG_REGULATOR_VEXPRESS) += vexpress-regulator.o
-+obj-$(CONFIG_REGULATOR_VQMMC_IPQ4019) += vqmmc-ipq4019-regulator.o
- obj-$(CONFIG_REGULATOR_WM831X) += wm831x-dcdc.o
- obj-$(CONFIG_REGULATOR_WM831X) += wm831x-isink.o
- obj-$(CONFIG_REGULATOR_WM831X) += wm831x-ldo.o
---- /dev/null
-+++ b/drivers/regulator/vqmmc-ipq4019-regulator.c
-@@ -0,0 +1,101 @@
-+// SPDX-License-Identifier: GPL-2.0+
-+//
-+// Copyright (c) 2019 Mantas Pucka <mantas@8devices.com>
-+// Copyright (c) 2019 Robert Marko <robert.marko@sartura.hr>
-+//
-+// Driver for IPQ4019 SD/MMC controller's I/O LDO voltage regulator
-+
-+#include <linux/io.h>
-+#include <linux/module.h>
-+#include <linux/of.h>
-+#include <linux/platform_device.h>
-+#include <linux/regmap.h>
-+#include <linux/regulator/driver.h>
-+#include <linux/regulator/machine.h>
-+#include <linux/regulator/of_regulator.h>
-+
-+static const unsigned int ipq4019_vmmc_voltages[] = {
-+      1500000, 1800000, 2500000, 3000000,
-+};
-+
-+static const struct regulator_ops ipq4019_regulator_voltage_ops = {
-+      .list_voltage = regulator_list_voltage_table,
-+      .map_voltage = regulator_map_voltage_ascend,
-+      .get_voltage_sel = regulator_get_voltage_sel_regmap,
-+      .set_voltage_sel = regulator_set_voltage_sel_regmap,
-+};
-+
-+static const struct regulator_desc vmmc_regulator = {
-+      .name           = "vmmcq",
-+      .ops            = &ipq4019_regulator_voltage_ops,
-+      .type           = REGULATOR_VOLTAGE,
-+      .owner          = THIS_MODULE,
-+      .volt_table     = ipq4019_vmmc_voltages,
-+      .n_voltages     = ARRAY_SIZE(ipq4019_vmmc_voltages),
-+      .vsel_reg       = 0,
-+      .vsel_mask      = 0x3,
-+};
-+
-+static const struct regmap_config ipq4019_vmmcq_regmap_config = {
-+      .reg_bits       = 32,
-+      .reg_stride     = 4,
-+      .val_bits       = 32,
-+};
-+
-+static int ipq4019_regulator_probe(struct platform_device *pdev)
-+{
-+      struct device *dev = &pdev->dev;
-+      struct regulator_init_data *init_data;
-+      struct regulator_config cfg = {};
-+      struct regulator_dev *rdev;
-+      struct resource *res;
-+      struct regmap *rmap;
-+      void __iomem *base;
-+
-+      init_data = of_get_regulator_init_data(dev, dev->of_node,
-+                                             &vmmc_regulator);
-+      if (!init_data)
-+              return -EINVAL;
-+
-+      res = platform_get_resource(pdev, IORESOURCE_MEM, 0);
-+      base = devm_ioremap_resource(dev, res);
-+      if (IS_ERR(base))
-+              return PTR_ERR(base);
-+
-+      rmap = devm_regmap_init_mmio(dev, base, &ipq4019_vmmcq_regmap_config);
-+      if (IS_ERR(rmap))
-+              return PTR_ERR(rmap);
-+
-+      cfg.dev = dev;
-+      cfg.init_data = init_data;
-+      cfg.of_node = dev->of_node;
-+      cfg.regmap = rmap;
-+
-+      rdev = devm_regulator_register(dev, &vmmc_regulator, &cfg);
-+      if (IS_ERR(rdev)) {
-+              dev_err(dev, "Failed to register regulator: %ld\n",
-+                      PTR_ERR(rdev));
-+              return PTR_ERR(rdev);
-+      }
-+      platform_set_drvdata(pdev, rdev);
-+
-+      return 0;
-+}
-+
-+static const struct of_device_id regulator_ipq4019_of_match[] = {
-+      { .compatible = "qcom,vqmmc-ipq4019-regulator", },
-+      {},
-+};
-+
-+static struct platform_driver ipq4019_regulator_driver = {
-+      .probe = ipq4019_regulator_probe,
-+      .driver = {
-+              .name = "vqmmc-ipq4019-regulator",
-+              .of_match_table = of_match_ptr(regulator_ipq4019_of_match),
-+      },
-+};
-+module_platform_driver(ipq4019_regulator_driver);
-+
-+MODULE_LICENSE("GPL");
-+MODULE_AUTHOR("Mantas Pucka <mantas@8devices.com>");
-+MODULE_DESCRIPTION("IPQ4019 VQMMC voltage regulator");