ipq806x: refresh 4.19 patches
[openwrt/openwrt.git] / target / linux / ipq806x / patches-4.19 / 0063-1-ipq806x-tsens-driver.patch
index 685b0c3ce18a581e271c67be8ba622080412cc96..9ee88533aac192b87d39b757ef2ab16f63d23d7e 100644 (file)
@@ -24,30 +24,13 @@ following fucntionalities:
 Change-Id: I8bc7204fd627d10875ab13fc1de8cb6c2ed7a918
 Signed-off-by: Rajith Cherian <rajith@codeaurora.org>
 ---
- .../devicetree/bindings/thermal/qcom-tsens.txt     |   1 +
- drivers/thermal/qcom/Makefile                      |   3 +-
- drivers/thermal/qcom/tsens-ipq8064.c               | 551 +++++++++++++++++++++
- drivers/thermal/qcom/tsens.c                       |   3 +
- drivers/thermal/qcom/tsens.h                       |   2 +-
- 5 files changed, 558 insertions(+), 2 deletions(-)
- create mode 100644 drivers/thermal/qcom/tsens-ipq8064.c
 
---- a/Documentation/devicetree/bindings/thermal/qcom-tsens.txt
-+++ b/Documentation/devicetree/bindings/thermal/qcom-tsens.txt
-@@ -5,6 +5,7 @@ Required properties:
-  - "qcom,msm8916-tsens" : For 8916 Family of SoCs
-  - "qcom,msm8974-tsens" : For 8974 Family of SoCs
-  - "qcom,msm8996-tsens" : For 8996 Family of SoCs
-+ - "qcom,ipq8064-tsens" : For IPQ8064
- - reg: Address range of the thermal registers
- - #thermal-sensor-cells : Should be 1. See ./thermal.txt for a description.
 --- a/drivers/thermal/qcom/Makefile
 +++ b/drivers/thermal/qcom/Makefile
 @@ -1,2 +1,3 @@
  obj-$(CONFIG_QCOM_TSENS)      += qcom_tsens.o
--qcom_tsens-y                  += tsens.o tsens-common.o tsens-8916.o tsens-8974.o tsens-8960.o tsens-8996.o
-+qcom_tsens-y                  += tsens.o tsens-common.o tsens-8916.o tsens-8974.o tsens-8960.o tsens-8996.o \
+-qcom_tsens-y                  += tsens.o tsens-common.o tsens-8916.o tsens-8974.o tsens-8960.o tsens-v2.o
++qcom_tsens-y                  += tsens.o tsens-common.o tsens-8916.o tsens-8974.o tsens-8960.o tsens-v2.o \
 +                              tsens-ipq8064.o
 --- /dev/null
 +++ b/drivers/thermal/qcom/tsens-ipq8064.c
@@ -605,23 +588,27 @@ Signed-off-by: Rajith Cherian <rajith@codeaurora.org>
 +};
 --- a/drivers/thermal/qcom/tsens.c
 +++ b/drivers/thermal/qcom/tsens.c
-@@ -72,6 +72,9 @@ static const struct of_device_id tsens_t
+@@ -75,8 +75,11 @@ static const struct of_device_id tsens_t
        }, {
-               .compatible = "qcom,msm8996-tsens",
-               .data = &data_8996,
+               .compatible = "qcom,tsens-v2",
+               .data = &data_tsens_v2,
 +      }, {
 +              .compatible = "qcom,ipq8064-tsens",
 +              .data = &data_ipq8064,
        },
-       {}
+-      {}
++      {}
  };
+ MODULE_DEVICE_TABLE(of, tsens_table);
 --- a/drivers/thermal/qcom/tsens.h
 +++ b/drivers/thermal/qcom/tsens.h
-@@ -89,6 +89,6 @@ void compute_intercept_slope(struct tsen
- int init_common(struct tsens_device *);
+@@ -89,7 +89,7 @@ int init_common(struct tsens_device *);
  int get_temp_common(struct tsens_device *, int, int *);
  
--extern const struct tsens_data data_8916, data_8974, data_8960, data_8996;
-+extern const struct tsens_data data_8916, data_8974, data_8960, data_8996, data_ipq8064;
+ /* TSENS v1 targets */
+-extern const struct tsens_data data_8916, data_8974, data_8960;
++extern const struct tsens_data data_8916, data_8974, data_8960, data_ipq8064;
+ /* TSENS v2 targets */
+ extern const struct tsens_data data_8996, data_tsens_v2;
  
- #endif /* __QCOM_TSENS_H__ */