ixp4xx: Add USRobotics USR8200 support
[openwrt/openwrt.git] / target / linux / ixp4xx / image / Makefile
index 0bcabe2db143c7cdaba72ae0834da7a80528e662..c6d4817c966f7c05d1687f8105553b42725d6d6f 100644 (file)
@@ -74,4 +74,17 @@ define Device/linksys_nslu2
 endef
 TARGET_DEVICES += linksys_nslu2
 
+define Device/usrobotics_usr8200
+       DEVICE_VENDOR := USRobotics
+       DEVICE_MODEL := USR8200
+       # USB2 is compiled in and needs no package
+       DEVICE_PACKAGES := ixp4xx-microcode-ethernet kmod-rtc-r7301 kmod-firewire kmod-firewire-ohci
+       DEVICE_DTS := intel-ixp42x-usrobotics-usr8200
+       KERNEL := kernel-bin | append-dtb
+       IMAGES := kernel.bin rootfs.bin
+       IMAGE/kernel.bin := append-kernel
+       IMAGE/rootfs.bin := append-rootfs | pad-rootfs | pad-to 128k
+endef
+TARGET_DEVICES += usrobotics_usr8200
+
 $(eval $(call BuildImage))