mips: use -mno-branch-likely for kernel and userspace, saves ~11k kernel size after...
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index d0eb2df1be81d931e4b93b18d989fb82e71af2fd..84958df7f65c027d55054c3d9ea6023a6e0e97fa 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS=xway ase falcon
 
 LINUX_VERSION:=3.7.1
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
 define Target/Description
        Build firmware images for Lantiq SoC