lantiq: use soc_vendor_device scheme on DTS file
[openwrt/openwrt.git] / target / linux / lantiq / image / Makefile
index a2052ef9249d76c98176447793c4be622e5f5159..3060ff920b9a25c417c0ae27f05edc8fd614efa0 100644 (file)
@@ -61,6 +61,8 @@ define Device/Default
   KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
   FILESYSTEMS := squashfs
   IMAGE_SIZE :=
+  DTS_DIR := $(DTS_DIR)/lantiq
+  DEVICE_DTS = $$(SOC)_$(1)
   SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
   IMAGES := sysupgrade.bin
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)