fix i2c-lantiq module
[openwrt/openwrt.git] / target / linux / lantiq / modules.mk
index 902231870312bdc13ba66e0072a6b19bd56465c4..e7fbad3a29590f924c8349c34125bb73ddbf96c5 100644 (file)
@@ -5,18 +5,18 @@
 # See /LICENSE for more information.
 #
 
-I2C_FALCON_MODULES:= \
-  CONFIG_I2C_FALCON:drivers/i2c/busses/i2c-falcon
+I2C_LANTIQ_MODULES:= \
+  CONFIG_I2C_LANTIQ:drivers/i2c/busses/i2c-lantiq
 
-define KernelPackage/i2c-falcon-lantiq
-  TITLE:=Falcon I2C controller
-  $(call i2c_defaults,$(I2C_FALCON_MODULES),52)
-  DEPENDS:=kmod-i2c-core @(TARGET_lantiq_falcon||TARGET_lantiq_falcon_stable)
+define KernelPackage/i2c-lantiq
+  TITLE:=Lantiq I2C controller
+  $(call i2c_defaults,$(I2C_LANTIQ_MODULES),52)
+  DEPENDS:=kmod-i2c-core @TARGET_lantiq_falcon
 endef
 
-define KernelPackage/i2c-falcon-lantiq/description
-  Kernel support for the Falcon I2C controller
+define KernelPackage/i2c-lantiq/description
+  Kernel support for the Lantiq/Falcon I2C controller
 endef
 
-$(eval $(call KernelPackage,i2c-falcon-lantiq))
+$(eval $(call KernelPackage,i2c-lantiq))