mediatek: mt7622: add Linux 5.10 support
[openwrt/openwrt.git] / target / linux / mediatek / Makefile
index f1836939a39ca2dcbbdaa0185fac6a2a60d88ccb..e2e44c78bbaa688b8f80cd5d50492dc2f7385880 100644 (file)
@@ -5,18 +5,14 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=mediatek
 BOARDNAME:=MediaTek Ralink ARM
-FEATURES:=squashfs nand ubifs
-CPU_TYPE:=cortex-a7
-CPU_SUBTYPE:=neon-vfpv4
-MAINTAINER:=John Crispin <john@phrozen.org>
+SUBTARGETS:=mt7622 mt7623 mt7629
+FEATURES:=squashfs nand seperate_ramdisk fpu
 
-KERNEL_PATCHVER:=4.9
-
-KERNELNAME:=Image dtbs zImage
+KERNEL_PATCHVER:=5.4
+KERNEL_TESTING_PATCHVER:=5.10
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += \
-       kmod-mt76 kmod-leds-gpio kmod-gpio-button-hotplug \
-       wpad-mini
+       kmod-leds-gpio kmod-gpio-button-hotplug
 
 $(eval $(call BuildTarget))