mediatek: mt7622: add Linux 5.10 support
[openwrt/openwrt.git] / target / linux / mediatek / files-5.10 / drivers / net / phy / mtk / mt753x / Makefile
diff --git a/target/linux/mediatek/files-5.10/drivers/net/phy/mtk/mt753x/Makefile b/target/linux/mediatek/files-5.10/drivers/net/phy/mtk/mt753x/Makefile
new file mode 100644 (file)
index 0000000..7aae451
--- /dev/null
@@ -0,0 +1,11 @@
+#
+# Makefile for MediaTek MT753x gigabit switch
+#
+
+obj-$(CONFIG_MT753X_GSW)       += mt753x.o
+
+mt753x-$(CONFIG_SWCONFIG)      += mt753x_swconfig.o
+
+mt753x-y                       += mt753x_mdio.o mt7530.o mt7531.o \
+                                       mt753x_common.o mt753x_vlan.o \
+                                       mt753x_nl.o