mpc85xx: add support for OCEDO Panda
[openwrt/openwrt.git] / target / linux / mpc85xx / image / Makefile
index e803cabcbe9e5c0902e602e36f3c916494b8bef9..57f1fba49931963b1377e68d621965b7894ca818 100644 (file)
@@ -90,6 +90,20 @@ define Device/hiveap-330
 endef
 TARGET_DEVICES += hiveap-330
 
+define Device/panda
+  DEVICE_TITLE := OCEDO Panda
+  DEVICE_PACKAGES := kmod-rtc-ds1307 kmod-usb2 uboot-envtools
+  KERNEL = kernel-bin | gzip | fit gzip $(KDIR)/image-$$(DEVICE_DTS).dtb
+  PAGESIZE := 2048
+  SUBPAGESIZE := 512
+  BLOCKSIZE := 128k
+  SUPPORTED_DEVICES := ocedo,panda
+  IMAGES := fdt.bin sysupgrade.bin
+  IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+  IMAGE/fdt.bin := append-dtb
+endef
+TARGET_DEVICES += panda
+
 endif
 
 ifeq ($(SUBTARGET),p2020)