mpc85xx: add support for Freescale (NXP) P2020RDB
[openwrt/openwrt.git] / target / linux / mpc85xx / image / Makefile
index 00eed888740a18460877b492cba59c4d2a31808a..dd15d4c610f8e6c232ba40611415eda8e36d11d4 100644 (file)
@@ -79,4 +79,23 @@ TARGET_DEVICES += hiveap-330
 
 endif
 
+ifeq ($(SUBTARGET),p2020)
+
+define Device/p2020rdb
+  DEVICE_TITLE := Freescale P2020RDB
+  DEVICE_DTS_DIR := $(DTS_DIR)/fsl
+  DEVICE_PACKAGES := kmod-hwmon-core kmod-hwmon-lm90 kmod-rtc-ds1307 \
+       kmod-gpio-pca953x kmod-eeprom-at24
+  BLOCKSIZE := 128k
+  KERNEL := kernel-bin | gzip | \
+       fit gzip $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+  SUPPORTED_DEVICES := fsl,P2020RDB
+  IMAGES := sysupgrade.bin
+  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
+       pad-rootfs $$(BLOCKSIZE) | append-metadata
+endef
+TARGET_DEVICES += p2020rdb
+
+endif
+
 $(eval $(call BuildImage))