mvebu: use SOC to derive DEVICE_DTS
[openwrt/openwrt.git] / target / linux / mvebu / image / cortex-a53.mk
index e58a3c42b9c19394941775e794296c84b607b7fc..73bd61f22e31cacded18fe42c7c876072d0c48f5 100644 (file)
@@ -6,7 +6,7 @@ define Device/globalscale_espressobin
   DEVICE_ALT0_VENDOR := Marvell
   DEVICE_ALT0_MODEL := Armada 3700 Community Board
   DEVICE_ALT0_VARIANT := Non-eMMC
-  DEVICE_DTS := armada-3720-espressobin
+  SOC := armada-3720
 endef
 TARGET_DEVICES += globalscale_espressobin
 
@@ -18,7 +18,7 @@ define Device/globalscale_espressobin-emmc
   DEVICE_ALT0_VENDOR := Marvell
   DEVICE_ALT0_MODEL := Armada 3700 Community Board
   DEVICE_ALT0_VARIANT := eMMC
-  DEVICE_DTS := armada-3720-espressobin-emmc
+  SOC := armada-3720
 endef
 TARGET_DEVICES += globalscale_espressobin-emmc
 
@@ -30,7 +30,7 @@ define Device/globalscale_espressobin-v7
   DEVICE_ALT0_VENDOR := Marvell
   DEVICE_ALT0_MODEL := Armada 3700 Community Board
   DEVICE_ALT0_VARIANT := V7 Non-eMMC
-  DEVICE_DTS := armada-3720-espressobin-v7
+  SOC := armada-3720
 endef
 TARGET_DEVICES += globalscale_espressobin-v7
 
@@ -42,7 +42,7 @@ define Device/globalscale_espressobin-v7-emmc
   DEVICE_ALT0_VENDOR := Marvell
   DEVICE_ALT0_MODEL := Armada 3700 Community Board
   DEVICE_ALT0_VARIANT := V7 eMMC
-  DEVICE_DTS := armada-3720-espressobin-v7-emmc
+  SOC := armada-3720
 endef
 TARGET_DEVICES += globalscale_espressobin-v7-emmc