mxs: - bump target to 3.14.14 - update dcp module
[openwrt/openwrt.git] / target / linux / mxs / modules.mk
index 0584a731bd33085043799fe44a5fc9092451e37f..3f9c8f8334e7a0df67dececb49b4369e42861f25 100644 (file)
@@ -89,9 +89,9 @@ $(eval $(call KernelPackage,iio-mxs-lradc))
 define KernelPackage/crypto-hw-dcp
     TITLE:=i.MX23/28 DCP hardware crypto module
     DEPENDS:=@TARGET_mxs
-    KCONFIG:=CONFIG_CRYPTO_DEV_DCP
-    FILES:=$(LINUX_DIR)/drivers/crypto/dcp.ko
-    AUTOLOAD:=$(call AutoLoad,90,dcp)
+    KCONFIG:=CONFIG_CRYPTO_DEV_MXS_DCP
+    FILES:=$(LINUX_DIR)/drivers/crypto/mxs-dcp.ko
+    AUTOLOAD:=$(call AutoLoad,90,mxs-dcp)
     $(call AddDepends/crypto,+kmod-crypto-authenc +kmod-crypto-des)
 endef