mxs: i2c changes - add package for i2c module - remove i2c debug
[openwrt/openwrt.git] / target / linux / mxs / modules.mk
index afcf23865c1ed7813628aa4926bacf86f3f2eac7..75d668a1d098ce736b420c76665c911a286e8359 100644 (file)
@@ -99,3 +99,18 @@ define KernelPackage/spi-mxs/description
 endef
 
 $(eval $(call KernelPackage,spi-mxs))
+
+I2C_MXS_MODULES:= \
+  CONFIG_I2C_MXS:drivers/i2c/busses/i2c-mxs
+
+define KernelPackage/i2c-mxs
+  $(call i2c_defaults,$(I2C_MXS_MODULES),55)
+  TITLE:=Freescale i.MX23/28 I2C driver
+  DEPENDS:=@TARGET_mxs +kmod-i2c-core
+endef
+
+define KernelPackage/i2c-mxs/description
+    Kernel module for Freescale i.MX23/28 I2C controller
+endef
+
+$(eval $(call KernelPackage,i2c-mxs))