netlogic: add XLR/XLP support
[openwrt/openwrt.git] / target / linux / netlogic / Makefile
diff --git a/target/linux/netlogic/Makefile b/target/linux/netlogic/Makefile
new file mode 100644 (file)
index 0000000..e3aa572
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips64
+BOARD:=netlogic
+BOARDNAME:=Broadcom/Netlogic XLP/XLR
+FEATURES:=squashfs jffs2 ext4 pci usb
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+SUBTARGETS:=xlp xlr
+
+LINUX_VERSION:=3.14.16
+
+include $(INCLUDE_DIR)/target.mk
+
+$(eval $(call BuildTarget))