Add basic framework for the openmoko platform. The kernel does build and boot, but...
[openwrt/openwrt.git] / target / linux / openmoko / Makefile
diff --git a/target/linux/openmoko/Makefile b/target/linux/openmoko/Makefile
new file mode 100644 (file)
index 0000000..22bfaea
--- /dev/null
@@ -0,0 +1,24 @@
+# 
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=openmoko
+BOARDNAME:=Openmoko
+FEATURES:=squashfs usb
+
+LINUX_VERSION:=2.6.24.7
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="uImage"
+
+define Target/Description
+  Build fimware images for the Openmoko Smartphone.
+endef
+
+$(eval $(call BuildTarget))