orion: rename patches directory to patches-3.18
[openwrt/openwrt.git] / target / linux / orion / patches-3.18 / 200-dt2_board_support.patch
diff --git a/target/linux/orion/patches-3.18/200-dt2_board_support.patch b/target/linux/orion/patches-3.18/200-dt2_board_support.patch
new file mode 100644 (file)
index 0000000..59a377f
--- /dev/null
@@ -0,0 +1,26 @@
+--- a/arch/arm/mach-orion5x/Kconfig
++++ b/arch/arm/mach-orion5x/Kconfig
+@@ -36,6 +36,13 @@ config MACH_RD88F5182_DT
+         Say 'Y' here if you want your kernel to support the Marvell
+         Orion-NAS (88F5182) RD2, Flattened Device Tree.
+
++config MACH_DT2
++      bool "Freecom DataTank Gateway"
++      select I2C_BOARDINFO
++      help
++        Say 'Y' here if you want your kernel to support the
++        Freecom DataTank Gateway
++
+ config MACH_KUROBOX_PRO
+       bool "KuroBox Pro"
+       select I2C_BOARDINFO
+--- a/arch/arm/mach-orion5x/Makefile
++++ b/arch/arm/mach-orion5x/Makefile
+@@ -14,6 +14,7 @@ obj-$(CONFIG_MACH_TS78XX)    += ts78xx-setu
+ obj-$(CONFIG_MACH_MV2120)     += mv2120-setup.o
+ obj-$(CONFIG_MACH_NET2BIG)    += net2big-setup.o
+ obj-$(CONFIG_MACH_WNR854T)    += wnr854t-setup.o
++obj-$(CONFIG_MACH_DT2)                += dt2-setup.o
+ obj-$(CONFIG_MACH_RD88F5181L_GE)      += rd88f5181l-ge-setup.o
+ obj-$(CONFIG_MACH_RD88F5181L_FXO)     += rd88f5181l-fxo-setup.o
+ obj-$(CONFIG_MACH_RD88F6183AP_GE)     += rd88f6183ap-ge-setup.o