oxnas: add patches and config for Linux 4.4
[openwrt/openwrt.git] / target / linux / oxnas / patches-4.4 / 330-oxnas-pinctrl.patch
diff --git a/target/linux/oxnas/patches-4.4/330-oxnas-pinctrl.patch b/target/linux/oxnas/patches-4.4/330-oxnas-pinctrl.patch
new file mode 100644 (file)
index 0000000..479bfdd
--- /dev/null
@@ -0,0 +1,28 @@
+--- a/drivers/pinctrl/Kconfig
++++ b/drivers/pinctrl/Kconfig
+@@ -227,6 +227,15 @@ config PINCTRL_COH901
+         COH 901 335 and COH 901 571/3. They contain 3, 5 or 7
+         ports of 8 GPIO pins each.
++config PINCTRL_OXNAS
++      bool "OXNAS pinctrl driver"
++      depends on OF
++      depends on ARCH_OXNAS
++      select PINMUX
++      select PINCONF
++      help
++        Say Y here to enable the oxnas pinctrl driver
++
+ config PINCTRL_PALMAS
+       bool "Pinctrl driver for the PALMAS Series MFD devices"
+       depends on OF && MFD_PALMAS
+--- a/drivers/pinctrl/Makefile
++++ b/drivers/pinctrl/Makefile
+@@ -17,6 +17,7 @@ obj-$(CONFIG_PINCTRL_AMD)    += pinctrl-amd
+ obj-$(CONFIG_PINCTRL_DIGICOLOR)       += pinctrl-digicolor.o
+ obj-$(CONFIG_PINCTRL_FALCON)  += pinctrl-falcon.o
+ obj-$(CONFIG_PINCTRL_MESON)   += meson/
++obj-$(CONFIG_PINCTRL_OXNAS)   += pinctrl-oxnas.o
+ obj-$(CONFIG_PINCTRL_PALMAS)  += pinctrl-palmas.o
+ obj-$(CONFIG_PINCTRL_PISTACHIO)       += pinctrl-pistachio.o
+ obj-$(CONFIG_PINCTRL_ROCKCHIP)        += pinctrl-rockchip.o