oxnas: switch to Linux 5.10
[openwrt/openwrt.git] / target / linux / oxnas / patches-5.4 / 150-oxnas-restart.patch
diff --git a/target/linux/oxnas/patches-5.4/150-oxnas-restart.patch b/target/linux/oxnas/patches-5.4/150-oxnas-restart.patch
deleted file mode 100644 (file)
index 79fbd9c..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/drivers/power/reset/Kconfig
-+++ b/drivers/power/reset/Kconfig
-@@ -123,6 +123,12 @@ config POWER_RESET_OCELOT_RESET
-       help
-         This driver supports restart for Microsemi Ocelot SoC.
-+config POWER_RESET_OXNAS
-+      bool "OXNAS SoC restart driver"
-+      depends on ARCH_OXNAS
-+      help
-+        Restart support for OXNAS boards.
-+
- config POWER_RESET_PIIX4_POWEROFF
-       tristate "Intel PIIX4 power-off driver"
-       depends on PCI
---- a/drivers/power/reset/Makefile
-+++ b/drivers/power/reset/Makefile
-@@ -11,6 +11,7 @@ obj-$(CONFIG_POWER_RESET_GPIO) += gpio-p
- obj-$(CONFIG_POWER_RESET_GPIO_RESTART) += gpio-restart.o
- obj-$(CONFIG_POWER_RESET_HISI) += hisi-reboot.o
- obj-$(CONFIG_POWER_RESET_MSM) += msm-poweroff.o
-+obj-$(CONFIG_POWER_RESET_OXNAS) += oxnas-restart.o
- obj-$(CONFIG_POWER_RESET_QCOM_PON) += qcom-pon.o
- obj-$(CONFIG_POWER_RESET_OCELOT_RESET) += ocelot-reset.o
- obj-$(CONFIG_POWER_RESET_PIIX4_POWEROFF) += piix4-poweroff.o