build: move elx-header into image-commands.mk
[openwrt/openwrt.git] / target / linux / ramips / image / Makefile
index 2fb13dcf08dd1786d1b9d40f5b1fdbb7a9c75e56..21bd135a62617740117c9b934c7c2dc1dc23800d 100644 (file)
@@ -35,26 +35,6 @@ define Build/edimax-header
        @mv $@.new $@
 endef
 
-define Build/elx-header
-       $(eval hw_id=$(word 1,$(1)))
-       $(eval xor_pattern=$(word 2,$(1)))
-       ( \
-               echo -ne "\x00\x00\x00\x00\x00\x00\x00\x03" | \
-                       dd bs=42 count=1 conv=sync; \
-               hw_id="$(hw_id)"; \
-               echo -ne "\x$${hw_id:0:2}\x$${hw_id:2:2}\x$${hw_id:4:2}\x$${hw_id:6:2}" | \
-                       dd bs=20 count=1 conv=sync; \
-               echo -ne "$$(printf '%08x' $$(stat -c%s $@) | fold -s2 | xargs -I {} echo \\x{} | tr -d '\n')" | \
-                       dd bs=8 count=1 conv=sync; \
-               echo -ne "$$($(STAGING_DIR_HOST)/bin/mkhash md5 $@ | fold -s2 | xargs -I {} echo \\x{} | tr -d '\n')" | \
-                       dd bs=58 count=1 conv=sync; \
-       ) > $(KDIR)/tmp/$(DEVICE_NAME).header
-       $(call Build/xor-image,-p $(xor_pattern) -x)
-       cat $(KDIR)/tmp/$(DEVICE_NAME).header $@ > $@.new
-       mv $@.new $@
-       rm -rf $(KDIR)/tmp/$(DEVICE_NAME).header
-endef
-
 define Build/jcg-header
        $(STAGING_DIR_HOST)/bin/jcgimage -v $(1) \
                $(if $(JCG_MAXSIZE), -m $$(($(subst k, * 1024,$(JCG_MAXSIZE)))),) \