ramips: make the relocation address configurable
[openwrt/openwrt.git] / target / linux / ramips / image / Makefile
index ac256cf1ae0e88140a8b834e11152362ada9ece8..241b6209411c3f43aca057c1ad27e87edbc5f2d0 100644 (file)
@@ -113,7 +113,7 @@ endef
 define Build/relocate-kernel
        rm -rf $@.relocate
        $(CP) ../../generic/image/relocate $@.relocate
-       $(MAKE) -C $@.relocate KERNEL_ADDR=$(KERNEL_LOADADDR) CROSS_COMPILE=$(TARGET_CROSS)
+       $(MAKE) -C $@.relocate KERNEL_ADDR=$(if $(1),$(1),$(KERNEL_LOADADDR)) CROSS_COMPILE=$(TARGET_CROSS)
        ( \
                dd if=$@.relocate/loader.bin bs=32 conv=sync && \
                perl -e '@s = stat("$@"); print pack("V", @s[7])' && \