ramips: add support for netis WF2770
[openwrt/openwrt.git] / target / linux / ramips / image / Makefile
index 4806226fd09342abdf76d495ad7add374455272c..b00e6d8726ebb07e3f15cf16cc5e766b2daa855b 100644 (file)
@@ -100,6 +100,12 @@ define Build/mkdlinkfw-factory
        mv $@.new $@
 endef
 
+define Build/netis-tail
+       echo -n $(1) >> $@
+       echo -n $(UIMAGE_NAME)-yun | $(STAGING_DIR_HOST)/bin/mkhash md5 | \
+               sed 's/../\\\\x&/g' | xargs echo -ne >> $@
+endef
+
 define Build/poray-header
        $(STAGING_DIR_HOST)/bin/mkporayfw $(1) -f $@ -o $@.new
        mv $@.new $@